9
$\begingroup$

I just followed Andrew Price's video tutorial on how to render hair in cycles, and I have followed every single direction, but no hair gets rendered. Is something not enabled or activated?

It is almost like it is trying to render with the particles grit there.

enter image description here enter image description here

Here is the blend file.

$\endgroup$
8
$\begingroup$

You may need to enable experimental features in the render tab for Cycles to render hair.

If you have an older version of blender and want to render hair on the GPU, you'll need to get a newer build from builder.blender.org or graphicall.org

Experimental Feature Set

$\endgroup$
  • $\begingroup$ You may need to specify how to do this. $\endgroup$ – A Wild RolandiXor Sep 3 '13 at 6:03
  • $\begingroup$ In the last blender release (2.68a) it's already implemented. You don't need to download a build . The official version of blender, downloadable on blender.org, have already this feature. $\endgroup$ – lucblender Sep 3 '13 at 19:20
  • $\begingroup$ I have the newest version but it wont work for some reason and yes it is set to experimental $\endgroup$ – Nikki Park Sep 4 '13 at 0:51
  • $\begingroup$ @NikkiPark Could you upload your blendfile or some screenshots of your particle settings? Right now it could be many things and we can't do much more than speculate. $\endgroup$ – gandalf3 Sep 4 '13 at 1:38
  • $\begingroup$ Here is the file. pasteall.org/blend/23841 $\endgroup$ – Nikki Park Sep 4 '13 at 1:43
3
$\begingroup$

It's probably because your particles are too small. You can see in your image that they are being rendered, but they're tiny.

The settings have changed since BG made his tutorial. There's now an additional factor, Scale, which, if I recall, is by default set to 0.05. Scale this up to 1 (or scale the root down by a factor of 20) and you should see better results.

I had this same issue when porting a Blender 2.66 file to Blender 2.67 – suddenly, all my hair was "gone!" But setting this value correctly should fix you up real good.

$\endgroup$
  • $\begingroup$ how do I change the size of the particles!!!!????? $\endgroup$ – Nikki Park Sep 4 '13 at 2:27
  • $\begingroup$ @Nikki see my edit. $\endgroup$ – wchargin Sep 4 '13 at 2:28
  • $\begingroup$ Where do I change the scale? $\endgroup$ – Nikki Park Sep 4 '13 at 2:31
  • $\begingroup$ In the particle settings, next to Root and Tip. $\endgroup$ – wchargin Sep 4 '13 at 2:31
  • 2
    $\begingroup$ @NikkiPark if this is the correct answer for your question, please mark it as such for future googlers with the same problem $\endgroup$ – Greg Zaal Sep 5 '13 at 9:49
3
$\begingroup$

As it turns out, you have to be out of Particle Mode before you render or the hair will not appear. I'm using 2.71

$\endgroup$
  • $\begingroup$ @someonewithpc Did you test it? It's not the issue in this particular question, but he is correct that hair doesn't seem to be rendered in particle edit mode. $\endgroup$ – gandalf3 Aug 7 '14 at 21:12
  • $\begingroup$ @someonewithpc could you please elaborate so all of us can learn? $\endgroup$ – cegaton Aug 7 '14 at 21:13
  • $\begingroup$ Sorry; let's say that I wasn't in the best conditions yesterday... $\endgroup$ – someonewithpc Aug 8 '14 at 9:10
  • $\begingroup$ I think because it will require to update for example the render if you are inside particle editor for hair (you can't change real time the look/combing of the hair)... so maybe they did choose to not put hair if you are editing hair.... 1.75a and it works this way. $\endgroup$ – tyoc213 Jul 26 '15 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.