2
$\begingroup$

Here is the picture of my object:

enter image description here

As you can see there are sharp edges from the top to the bottom of the object. But the thing is I haven't found any solution to counter this however.

The only solution I had tried is Object > Shade Smooth. But here are it's results:

enter image description here

Is there any way to solve this?, thanks!

$\endgroup$
5
  • $\begingroup$ Hello, are your talking about the shading or about the contour? These are 2 different things. If you're talking about the contour, you can bevel the edges $\endgroup$
    – moonboots
    Jul 4 at 8:39
  • $\begingroup$ I'm talking about this: all3dp.com/2/blender-smooth-shading-simply-explained $\endgroup$
    – FerbiZides
    Jul 4 at 9:22
  • $\begingroup$ you say "Is there any way to solve this?", what are you refering to? what bothers you in the image? $\endgroup$
    – moonboots
    Jul 4 at 9:25
  • $\begingroup$ The black glows somehow bother me. $\endgroup$
    – FerbiZides
    Jul 4 at 9:26
  • $\begingroup$ @FerbiZides you could fix that by auto smooth $\endgroup$ Jul 4 at 18:25

3 Answers 3

3
$\begingroup$

At first, to make the smooth shading look less weird you should enable Normals > Auto Smooth in the Object Data Properties.

auto smooth

If you now also want the edges to be smoothed or rounded off, I would suggest you use the Bevel Modifier. This way you can non-destructively smoothen the edges and make changes afterwards if needed.

Go to the Modifier Properties tab, click on Add Modifier and choose Bevel. Then you can adjust the Amount and Segments to your liking. The Limit Method is by default set to Angle, with a default value of 30°. On my model I've lowered it to 24° to get the bottom edges beveled as well. What I would also suggest is to disable Geometry > Loop Slide and enable Shading > Harden Normals.

bevel modifier

$\endgroup$
2
$\begingroup$

One of my favorite ways to do this is by combining a Bevel modifier with a SubSurf modifier.

SubSurf is great because it can't be beat in terms of smoothing out the geometry of your model. Only problem is it takes the manual addition of edge loops all along every edge you want to keep relatively sharp, which is time-consuming and difficult to edit.

enter image description here

If you don't add these in you get a model that looks like this:

enter image description here

Not great.

However, if you use a Bevel modifier, with the profile set to 1, and set the Limit Method to Angle, you can almost get 100% of your edge-loops for free.

enter image description here

It's not entirely fool-proof though. Spots like here on the bot

enter image description here

So in this example it's not exactly 100% automatic, 90% of the objects you try this method on, this will get you what you need.

We just need to do two things:

Select the front face and press "I" to inset it a bit.

enter image description here

Then in edge select mode, go to Select>Sharp Edges. This get's us nearly all we want.

enter image description here enter image description here

We just need to figure out a way to get these edges in there. enter image description here

Which in this exact scenario we can do by using Select > Loops > Edge Loops.

enter image description here enter image description here

And then Ctrl+E > Edge Bevel Weight and type in 1 on the numpad.

enter image description here

Now we have all the edges that we want beveled marked as such.

enter image description here

Incidentally, this is what the first versions of HardOps did way back in the day; automate this whole process to make it a 1-click deal.

Now you can just push Ctrl+1 to add a SubSurf modifier with 1 level of subdivision, and we're looking good. Also set it to shade smooth, auto smooth and, if needed, a Weighted Normal modifier.

enter image description here

$\endgroup$
4
  • $\begingroup$ Why not just use a bevel? $\endgroup$ Jul 4 at 9:34
  • $\begingroup$ @YousufChaudhry My thoughts exactly. This is a quite simple object and bevel or the Bevel Modifier would be absolutely sufficient to achieve that. I would only suggest to deactivate Loop Slide for the bevel. $\endgroup$ Jul 4 at 9:49
  • 1
    $\begingroup$ @YousufChaudhry. this is why $\endgroup$
    – Jakemoyo
    Jul 4 at 12:22
  • $\begingroup$ @Jakemoyo You've got a point ;) $\endgroup$ Jul 4 at 18:24
0
$\begingroup$

I had found a solution (geometry absolutely bonkers though):

  1. Select all of the sharp edges:

enter image description here

  1. Bevel all of them and set the segments to 10.
  2. Add 2 modifiers called "Edge Split" and "Subdivision Surface".

Detailed note for the 2 modifiers:

enter image description here

And if you had done all of that, this should be the result: enter image description here

This solution is enough for me as I will only texture it and export it, with nothing else in mind.

$\endgroup$
3
  • 1
    $\begingroup$ Well, you could have easily selected the two outside edge loops, marked them sharp, and add a bevel or subdiv to do what you did. Though I guess you didn't explain your end result. $\endgroup$ Jul 4 at 10:04
  • $\begingroup$ Or the above answer could have worked if you didn't add the two bottom sharp edges. $\endgroup$ Jul 4 at 10:05
  • $\begingroup$ Okay, my answer is for if you want to change something afterwards - but now that you said you want to export it, changing the mesh by beveling it in Edit Mode would be better. However, you don't need those modifiers for that result. First of all, select all three front faces and the corresponding faces on the back. Press F to join them. Then select the edges you want to bevel and do it. If you have set the object to smooth shading and it looks weird, enable Normals > Auto Smooth in the Object Data Properties. This will give you a better geometry as well. $\endgroup$ Jul 4 at 10:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.