3
$\begingroup$

When you are moving/rotating something in 3D, you're supposed to be able to hold shift for the precision mode where things move more slowly.

https://docs.blender.org/manual/en/latest/scene_layout/object/editing/transform/control/precision.html

That is no longer working for me, after upgrading to a new blender version. I've made sure snapping is off, but it's still no good; holding shift has no effect.

I'd appreciate any help with this. I'm sure I'm missing something obvious.

Edited to add: Reverting to the default keymap makes precision mode work again, but it doesn't work with my own key bindings. But it's supposedly hard-coded, and I have nothing bound to shift.

Other than manually writing down and re-entering hundreds of key bindings, does anyone have any thoughts as to what I might do?

$\endgroup$
8
  • $\begingroup$ Can you share the exact blend file you have that it's not working in? $\endgroup$
    – Jakemoyo
    Commented Jul 6, 2022 at 10:05
  • $\begingroup$ It isn't any particular blend file. It's anything in blender 3.0 or 3.1, even a blank new file. But I guess the closest thing would be to share my startup file, though I don't know if that'd be useful. (redid this, because I should have read the link I was sent on how to share. Sorry) blend-exchange.com/b/ZQn97xJz $\endgroup$ Commented Jul 7, 2022 at 1:15
  • $\begingroup$ That project file works for me, the precision move works on my end. However i do see a CUDA cuInit: Unknown error pop up in the console when I add an object, I'm not really sure if that is the problem, seems like a stretch, but it doesn't happen when I open my own startup file. Have you tried updating your graphics drivers? $\endgroup$
    – Jakemoyo
    Commented Jul 7, 2022 at 22:20
  • $\begingroup$ I suspected the file would work for you, but it was worth a try. It must be something in my configuration somewhere, I guess? I can't imagine what. Regarding the CUDA thing, my graphics drivers are up to date and I'm not having any rendering issues, so I don't know what that's about. $\endgroup$ Commented Jul 8, 2022 at 2:08
  • $\begingroup$ The GPU drivers can affect more than just rendering. Not saying its the case here, but it's not out of the question in some other scenarios. In any case, I would try loading factory settings, then enable all the addons you did have enabled one by one and see which one might trigger the issue to pop up. $\endgroup$
    – Jakemoyo
    Commented Jul 8, 2022 at 8:01

2 Answers 2

1
$\begingroup$

I found the problem. Hidden away at the bottom of the key mapping list is the "Transform Modal Map" category. If you add a new binding to that category, "Precision mode" is an option, even though that doesn't show up when you search binding names for some reason. precision mode location

$\endgroup$
0
$\begingroup$

These values seem to be hard-coded into the transform operator in C.I don't think there is a way to change it outside of writing a custom transform operator in Python or a custom build of Blender.

eRedrawFlag handleMouseInput(TransInfo *t, MouseInput *mi, const wmEvent *event)
{
  eRedrawFlag redraw = TREDRAW_NOTHING;

  switch (event->type) {
    case EVT_LEFTSHIFTKEY:
    case EVT_RIGHTSHIFTKEY:
      if (event->val == KM_PRESS) {
        t->modifiers |= MOD_PRECISION;
        /* shift is modifier for higher precision transforn */
        mi->precision = 1;
        redraw = TREDRAW_HARD;
      }
      else if (event->val == KM_RELEASE) {
        t->modifiers &= ~MOD_PRECISION;
        mi->precision = 0;
        redraw = TREDRAW_HARD;
      }
      break;
  }

  return redraw;
}
```
$\endgroup$
3
  • $\begingroup$ I see. The question is; if it's hard coded in, then why would the functionality not be working? Like I said, in blender 2.9, shift works to use precision transform mode, and in 3.x it just doesn't do anything for me. I'm very confused about this. To be clear, I'm only messing around with keymapping because I couldn't think of anything else it could be. The core problem is just that holding shift while transforming does not enable precision mode anymore, so I can't use precision mode. $\endgroup$ Commented Jul 4, 2022 at 19:12
  • 1
    $\begingroup$ It works for me, are you sure you're doing it with snapping disabled? You might consider editing this question. Sounds like your actual question is "Why is shift for precise transform not working?" not "how to remap precise transform hotkey?" $\endgroup$
    – Jakemoyo
    Commented Jul 5, 2022 at 9:59
  • $\begingroup$ Right, sorry. New to stackexchange so I don't quite know the norms yet. Yes, I've made sure snapping is off. $\endgroup$ Commented Jul 5, 2022 at 19:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .