2
$\begingroup$

I am trying to export my model into a gltf file. It includes a simple walk cycle animation. My issue is that each and every object of my model gets a seperate animation track after export.

BEFORE EXPORT

Before Export

AFTER EXPORT After Export

Outliner to Show Heirarchy

Outliner

Export Settings

enter image description here

How do I prevent the export from giving every object a seperate animation?

Thank you.

$\endgroup$

1 Answer 1

1
$\begingroup$

After a lack of response here, I posted the question to the Blender GLTF I/O github. So Julien Duroure, the lead maintainer of the addon had given me the solution.

The issue is that, in the export options. I set is as 'Limited to Selected Objects'. This causes all objects to have a baked animation.

So Julien had given me two solutions.

  • Don't use limits to selection
  • Use "Optimize Animation Size", that will remove animations that are constant (this was the case for my meshes)

In my case the 2nd option has worked fine. Cheers.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .