2
$\begingroup$

I'm trying to link baked texture files to my character. I have been using the SimpleBake add-on. My character turns pink as if Blender cannot find my texture files. As far as I can see, my texture files look just fine and well. I browse to them from the image texture node as I should. I even tried baking just one UDIM file hoping that should help. Nope. I've also tried File -> External Data -> Find missing files. Doesn't help. What am I doing wrong?

See images attached. Hopefully they can explain my problem.

enter image description here

$\endgroup$
9
  • $\begingroup$ Have you tried File > External Data > Report missing files? Maybe there is an HDRI missing? $\endgroup$
    – Blunder
    Jul 2, 2022 at 12:06
  • $\begingroup$ The tutorial I am following does not use HDRI. World colour is set to white. $\endgroup$ Jul 2, 2022 at 12:15
  • $\begingroup$ Ah ok. And what reports Blender when you use File > External Data > ...*? It should tell you if files are missing and where to find them. $\endgroup$
    – Blunder
    Jul 2, 2022 at 12:36
  • $\begingroup$ Yes, since I have been trying this over and over again I have a number of files from old versions reported missing. I have now retrieved them from my trashcan. I no longer get reports about missing files. Still, my character is pink. $\endgroup$ Jul 2, 2022 at 12:44
  • $\begingroup$ Have you checked if the images are present in the image editor (texture paint workspace)? The thumbnails are cached and the image can still be missing. But you should see images if you select them from the drop-down menu. In the side panel (key N) you can see the file path. Maybe it's because of the UDIMs? Is the Tiled option checked in the image settings? The files need a number in their filename, something like "skin normal.1001.png". $\endgroup$
    – Blunder
    Jul 2, 2022 at 19:49

1 Answer 1

1
$\begingroup$

It looks like there is something wrong with UDIMs as already mentioned in the comments. It's either a wrong filename, a wrong folder, wrong tile numbers, or wrong settings. I still wonder why you no longer get messages about missing files when you select the menu entry File > External Data > Report Missing Files of the main menu. To track down the error, here are two examples, one working and one with incorrect file names.

Here is a working UDIM example and a checklist.

  • in the Image Editor (1), select the image (2) and check if the images are loaded and shown (3)
  • in the side panel (N) (4) on the Image tab you will find the filename of the image. Source should be UDIM Tiles and in the filename, there should be a <UDIM> part. The UIDM tile numbers are shown below. The default values start at 1001.
  • in the file browser (5) check if the files are in the correct folder and have the correct names. Here the <UDIM> part in the filename must be replaced by the tile numbers, e.g. "primitives diffuse.1001.png", "primitives diffuse.1002.png", and so on.
  • in the Shader Editor, check if the Image Texture node (6) has set the source option to UDIM Tiles for the given UDIM image texture. screenshot everything is good

Here is an example of broken filenames.

The tile numbers in filenames are incorrect (1). In consequence,

  • (2) you still see the cached icon of the image. But there is an error message "Can't Load Image" under the filename and the images are not loaded and not shown.
  • (3) The models are pink and
  • (4) there should be a warning in the Info view after you run the File > External Data > Report Missing Files command. The command ... > Find Missing Files should also report the missing files if they cannot be found in the selected folder.

screenshot wrong filename

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .