4
$\begingroup$

so im working on a personal project and im trying to do a chimney that emmits smoke. I manage to get the particle system right but the animation of the particles going up is way too fast.

This is what looks like

The other big problem im facing is, how can i make this smoke interact with the roof of the chimney, so in that way the smoke dont clip through the roof, and go to the sides ?

Here is a simple way of showing of my problem

Thanks !

EDIT 01/07/2022

Manage to get the speed right with the help of Gordon Brinkmann, but still facing the interaction problem.

enter image description here

enter image description here

$\endgroup$

1 Answer 1

3
$\begingroup$

For the speed at which the particles rise: you have velocity settings for them which you can see in your screenshot. If you turn them down, they'll move slower.

Another possibility would be to have a value > 0 for Damp under Physics > Forces in the Particle Settings.

For the interaction with the chimney: I guess the chimney is already a Collision object, so to take the size of the smoke into account, you have to enable Size Deflect under Physics > Deflection. By default this is turned off and only the center of a particle is used for the collisions.

However, with randomly varying sizes you can get the problem that a particle is born which is too large to "escape" the chimney. I personally wouldn't mind too much if a larger particle goes "through" the rooftop of the chimney as smoke could also wrap around obstacles. Of course this wouldn't look perfect, but since you only have spherical particles and no real smoke, they won't deform around collision objects.

Physics > Forces and Deflection:

particle physics

$\endgroup$
3
  • $\begingroup$ Hey, after your instructions i manage to get the speed just right, it was really the Damp levels messing around, but i still have the problem with the interaction with the chimney, after i checked the Size Deflect Box the particles still go through the roof, i tried to use a collision modifier in the chimney itself so it interacts with the particles, but i doesn't seems the right way to do, the particles is very erratic behavior and goes everywhere. $\endgroup$ Jul 1 at 16:33
  • $\begingroup$ The Size Deflect uses the size which you have set under the Render settings where you choose which object to use for rendering the particles. I guess it might be depending on the scale of the object that the visible size differs from the set particle size. What do you mean with the collision modifier? For the collision with particle you need to enable Collision on the chimney found in the Physics tab, where you also find things like Rigid Body, Soft Body, Fluid and other simulations. $\endgroup$ Jul 1 at 17:39
  • 1
    $\begingroup$ It worked ! After i tried to adjust the size of the rendering particles i made a new plane at exactly the shape of the roof that i wanted to the particles colide and spread, i made this plane a convex shape, pointing downward to the botton of the chimney and assign this shape as Physics - Collision, that way when the particles is hitting the highest point of the convex shape they tend to spread outwards of the shape. Thanks ! $\endgroup$ Jul 1 at 21:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.