0
$\begingroup$

I have a blender render I'm trying to create, but my landscape looks messed up when I start the render. I used the hair feature to insert the trees in case that's significant at all. Any help would be greatly appreciated! Thanks in advance.

https://drive.google.com/file/d/13Ibd9Cwjiz3ZQyAPbn-hfAFZyN4QwYaD/view?usp=sharing

enter image description here

$\endgroup$
3
  • $\begingroup$ Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking. $\endgroup$
    – Community Bot
    Jun 30, 2022 at 13:27
  • $\begingroup$ Do you have your .blend file? Would you be able to share it for us to look at? $\endgroup$
    – Onyx
    Jun 30, 2022 at 14:00
  • $\begingroup$ Hi @Onyx ! Here it is. It may be a little disorganized because I'm new to blender, but let me know if you're able to download and open the file without any issues. Thanks! drive.google.com/file/d/13Ibd9Cwjiz3ZQyAPbn-hfAFZyN4QwYaD/… $\endgroup$
    – Damon
    Jun 30, 2022 at 15:21

1 Answer 1

0
$\begingroup$

screenshot

Your terrain mesh uses the Cloth simulation. This and the Subdivision Surface modifier cause the problem.

Is there a reason for a cloth simulation? It is not a good idea to add a Cloth modifier to a dense mesh because the simulation takes very long and can even freeze Blender. With level 1 of the Subdivision Surface modifier the terrain has around 325,000 vertices. That's a lot for a cloth simulation. If you want to simulate a movement of the earth maybe try the Displacement modifier. It can be animated as well.

The rendering problem that you see is because the Cloth simulation has no data at render time. It uses cached data that is generated when you run the animation in the viewport or when you bake it.

The data is missing because the Subdivision Surface modifier has different levels for the viewport and the render.

The modifier stack works top-down. So first, the Subdivision Surface modifier subdivides the mesh, then the trees (particles) are added to this mesh, and then it is deformed by the Cloth modifier for each frame.

The Subdivision Surface modifier at the top of the stack has the default settings, viewport level of 1, and a rendering level of 2. That is, at render time the modifier adds more vertices to smooth out the model. Usually, that's totally fine especially when this modifier is the last one on the stack.

But in your case, when you render the image, the Cloth modifier cannot use the simulated data because it is simulated for a mesh with one subdivision, but the mesh actually has two subdivisions.

To fix this, either

  • remove the Cloth modifier
  • or move it up before the Subdivision modifier
  • or decrease the render level of the Subdivision modifier to 1
$\endgroup$
1
  • $\begingroup$ You're amazing! It must've been an accident while I was trying to turn a different plane into a cloth. Thank you so much. I thought I was never going to figure it out. Have a fantastic day <3 $\endgroup$
    – Damon
    Jul 1, 2022 at 14:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .