1
$\begingroup$

I have 2 rather screenshots than textures enter image description here

What I do is projecting my front and back sides of a character mesh onto these pictures.

I do that in this consequence:

  1. assign a material to the mesh.
  2. assign a new material to front faces > projecting them onto 1st pic
  3. the same as the 2nd point but with the back side, selecting the back faces by inverting the first selection.

In result for some reason I get only one texture applied to the both sides, which can be switched by reordering them in material list. I want to admit that the front and back materials do have different textures assigned as base colors. enter image description here

$\endgroup$
4
  • $\begingroup$ If everything seems to be set up correctly but it's still not working, it would be best to upload the file for further investigation. $\endgroup$ Commented Jun 30, 2022 at 10:57
  • $\begingroup$ @GordonBrinkmann I've just noticed that for some reason material assigning not working at all on this particular mesh. $\endgroup$ Commented Jun 30, 2022 at 11:04
  • $\begingroup$ "material assigning not working at all" cannot be possible I'd say, you can always assign a material to a mesh with faces somehow, no matter if UV mapping etc. is correct or not. $\endgroup$ Commented Jun 30, 2022 at 11:06
  • $\begingroup$ @GordonBrinkmann I attached the blend file. $\endgroup$ Commented Jun 30, 2022 at 11:11

1 Answer 1

1
$\begingroup$

In the Solidify Modifier you have set Normals to Flip. This in combination with having the Material Offset to 4, which refers to the fifth material slot (counting starts at 0, but since you have only two materials 0 and 1 the highest number is used) results in using material 1 for all visible faces.

Just for info on the Material Offset and Rim materials: like the word "offset" implies, it is always the slots offset based on the faces material. Which means, say Material Offset is 1 and Rim is 2, than a face which uses material slot 0 will get slot 1 for the solidified face and slot 2 for the rim, whereas a face using e.g. material slot 2 will get slot 3's material for solidified faces and slot 4 as material for the rim. If you now set Normals to Flip, the solidified face shows the assigned material but the original face shows the offset material.

When using only a single material or by resetting the Material Offset to 0, this problem will disappear and show the correctly assigned materials. However, flipped normals can also cause other problems with materials in rendering and for physics simulations etc. so you should rather disable the Flip option (this also enables you to still use the offset if you need it for special materials on the solidified faces).

enter image description here

$\endgroup$
4
  • $\begingroup$ Ooh thank you very much! $\endgroup$ Commented Jun 30, 2022 at 11:26
  • $\begingroup$ Oh, no - I'm sorry! Although this helps, it shouldn't be necessary. Under Normals you have Flip enabled, that's the problem. In your case for assigning the materials this might not matter very much, but having the normals flipped might also cause other problems so I'll edit my answer. $\endgroup$ Commented Jun 30, 2022 at 11:33
  • $\begingroup$ Thanks again, I learned a lot from this! $\endgroup$ Commented Jun 30, 2022 at 11:40
  • $\begingroup$ No problem. Since the Normals menu wasn't unfolded I didn't look at it at first, but as soon as you turn on Face Orientation in the Overlays this becomes obvious. $\endgroup$ Commented Jun 30, 2022 at 11:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .