4
$\begingroup$

when I use the add on add curve:extra objects to create a curve spiral I am having a weird glitch

I want to have an open curve so i delete a vertex which some how results in the curve vertecies getting disconnected and a random location along the curve. I try and double click on all a vertex to highlight the curve and it appears the curve has gotten cut up.

I have been using this add on for months and it is all of a sudden acting super strange. attaching photos of me making the curve( converted into a mesh), adding a soldifer and subdivision enter image description hereenter image description hereenter image description here

$\endgroup$
8
  • 1
    $\begingroup$ If 'Cyclic' is not checked, the curve should be open without any deletion required, on your part..? $\endgroup$ Jun 30 at 7:57
  • $\begingroup$ Apart from possible other problems, there are definitely some double vertices. On the bottom of the upper image you can see a selected orange edge on a black, unselected vertex - which can only mean the real vertex of this edge lies below the one you see. Then the next edge to the left is black with an orange outline, which means there is a selected edge below the unselected edge - which also means there must be another selected vertex below an unselected vertex. $\endgroup$ Jun 30 at 11:04
  • $\begingroup$ By the way, which spiral object are you using? Because when I'm adding any of them, the edges are not showing in black, even if they are unselected... $\endgroup$ Jun 30 at 11:11
  • $\begingroup$ @GordonBrinkmann i'm confused by your statement but I am doing archamedian $\endgroup$
    – Brit
    Jun 30 at 14:16
  • 1
    $\begingroup$ @Brit because, typically, spirals are not cyclic :D ..Gordon has covered it. $\endgroup$ Jun 30 at 15:08

1 Answer 1

5
$\begingroup$

When you add a Curve > Curve Spirals > Archemedian object (or other spiral objects as well), the default setting for Height is 0. In this case the spiral looks like a closed circle (ever wondered why Spiral creates a circle?).

However, if you set the height to a value <> 0 you will see that it's not a closed circle but instead an open spiral where the first and last segment lie directly on top of each other, e.g. here I've set a height of 0.1:

spiral

This means there is no need for deleting vertices to get an open curve - actually, if Cyclic would have been enabled, deleting a vertex wouldn't create an open curve. You would only have a vertex less and the rest of the segments would be connected to keep the curve closed. And after you converted the curve to a mesh, there shouldn't be any Cyclic option to enable anymore.

$\endgroup$
2
  • $\begingroup$ it worked though when i chose cyclic and deleted a vertex , but that picture explains a part of that weird glitch $\endgroup$
    – Brit
    Jun 30 at 14:51
  • $\begingroup$ i think what was happening that made it work sometimes is I just happen to delete the 2 overlapping vertex so it never gave the glitch. but this makes sense. thank you! $\endgroup$
    – Brit
    Jun 30 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.