8
$\begingroup$

How can I tell Blender not to start applying physics until a certain frame? Is it possible? I have a very complicated shot, where a massive object is crashing though various different cell fractured elements, but despite having tried the Enable Deactivation/Start Deactivated and trying somehow to set up keyframes for the Dynamic check box, all of my objects that are supposed to activate when my large object interacts with them end up just breaking apart on their own free will at the beginning of the animation. Is there a solution I am missing?

$\endgroup$
5
$\begingroup$

To offset when a rigid body simulation starts, I would suggest that you use keyframing to your advantage. You can keyframe any option in blender, including the "Animate" and "Dynamic" check boxes in the rigid body options. Mouse over the "Animate" or "Dynamic" checkbox and press "i" like any other add keyframe. Off On You can then make it so that only when the object is hit, or at a certain time, will the object begin to fall. Likewise, you can also use this so that your fractured objects do not fall apart until they are hit or about to be hit. Hope this helps!

P.S.You can find a full tutorial detailing this sort of animation/simulation here. This is a three part tutorial (with a prequel teaching how to model the mug) made by Blender Cookie.

$\endgroup$
  • $\begingroup$ I've tried doing this with my fractured objects but I ran into an issue where setting up the keyframes on my active object (One of the fractured pieces) doesn't transfer those same keyframes over to the rest of my fractured objects, even if I hit COPY FROM ACTIVE in the RIGID BODY TOOLS. Is there a simple way to copy over the keyframes? $\endgroup$ – Daniel Mar 8 '15 at 21:19
  • $\begingroup$ Try using the dupe sheet to push the keyframes to the other objects. There are plenty of tutorials out there but its really intuitive. @Daniel $\endgroup$ – Dr. Who Mar 9 '15 at 22:28
1
$\begingroup$

When your rigid body objects start deactivated they need to be activated by another rigid body object.

enter image description here

This scene uses a cube to activate the simulation, this will also work when the cube is hidden from the scene and render by the visibility flags.

Settings for the cones:

enter image description here

Setting for the activating cube:

enter image description here

The information is already contained in @gandalf3 post here: Sequentially Enable Rigid Body Control

$\endgroup$
  • $\begingroup$ I have the scene set up this way already but it is not functioning properly. $\endgroup$ – Daniel Mar 8 '15 at 21:15
  • $\begingroup$ @David could you upload your .blend here:blend-exchange.giantcowfilms.com and add the link to your question. $\endgroup$ – stacker Mar 8 '15 at 21:54
0
$\begingroup$

I discovered a sphere didn't work for the object colliding with the fractured group. When I changed to a cube it worked fine. I'm still looking for a reason as to why (if anyone knows, please respond), but wanted to add this here in case anyone else was pulling their hair.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.