2
$\begingroup$

I've recently had a problem and I want to know how to fix it. My probleme is when I move the bones in rigify I don't want them to stretch, because when they stretch the leg or arm gets messy and taller than it should be.

My second question is: How do I deal with elbows controllers so that the arm looks real when rigging? My third question is: How do I add eyes and face controllers to the rig so that I can control expressions of face without messing with the body rigs

$\endgroup$
  • 2
    $\begingroup$ Please ask only one question at a time, you have three separate questions here. $\endgroup$ – David Mar 7 '15 at 19:44
  • $\begingroup$ well they're three questions for the same concept, Riggify $\endgroup$ – Ahmed Missoum Mar 7 '15 at 19:46
  • 1
    $\begingroup$ @AhmedMissoum It is still 3 separate questions: They are different enough to be easier to answer/more searchable as separate questions, please edit the post to remove the other two and ask them as separate questions $\endgroup$ – GiantCowFilms Mar 7 '15 at 20:23
2
$\begingroup$

The first two questions are related I will focus on them. The stretching you face only appears with inverse kinematics (IK) when you move the control bone in a impossible position, this is used for cartonic exaggeration.

You can disable this by setting the Auto Stretch IK slider to 0.

enter image description here

The elbow has an IK-target which can be controlled as knees with a ball shaped control.

enter image description here

$\endgroup$
0
$\begingroup$

The stretching can also be caused by the armature being scaled in the object mode. Check that all scale variables are set to one.

https://blenderartists.org/t/problem-with-bones-in-armature-streching-when-rotated/542671

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.