2
$\begingroup$

I am following this guide to make a world background.

World Background Image: Environment Texture does not scale right

How can I lock the world position?

enter image description here

$\endgroup$
1
  • $\begingroup$ Use Generated texture coordinate instead of Camera or Window $\endgroup$ Commented Jun 26, 2022 at 1:38

1 Answer 1

3
$\begingroup$

It looks like you're using Camera or Window coordinates for your world texture.

Change it to Generated (connect the Generated output of the Texture Coordinate node to your Image Texture node) to fix it.

(Also make sure you have Lock Camera To View unchecked in the N-menu > View tab.)

$\endgroup$
1
  • $\begingroup$ Thank you finally make my sun facing the road. X:90 Y:40 Z:180 $\endgroup$ Commented Jun 26, 2022 at 18:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .