3
$\begingroup$

I want to remodel blood vessels and have uploaded the thin-walled model in blender. To 3D print it, I need to increase the wall thickness to 0.5-1mm. I managed this well with the solidify tool. It happens that the vessels overlap,(shown in the second picture) which is a big problem for me. I don't mind if they touch each other, but the outer wall must not dip into/inside the other vessel.So the inside tube is the important one, which must be free of disturbance. Does anyone know how to do this? One idea would be to cut out the inner tube again at the end, and thus erase everything that comes inside. Unfortunately, I have never used blender and therefore do not know it. I am very happy about your help!

Kind regards Simon

enter image description here enter image description here

$\endgroup$
2
  • $\begingroup$ the idea is to remove an inner part and in this case you can control solidify how much "in" and "out" you want. $\endgroup$
    – Crantisz
    Commented Jun 22, 2022 at 13:44
  • $\begingroup$ I have edited my answer, check. $\endgroup$ Commented Jun 23, 2022 at 12:11

1 Answer 1

1
$\begingroup$

I take it you do not want to move the position of the vessels slightly...

So here are a few options:

The Boolean Modifier

Add a Boolean modifier to one of your vessels and select the other vessel as the Target Object. Set it to Difference (the default) and the other vessel won't be visible inside the other vessel.

Offset Of the Solidify Modifier

There is an Offset option in the solidify modifier. Play with those values until you get your desired result.

Moving your vessels slightly

If the boolean still doesn't work because the vessels are intersecting too much, you can slightly move your vessels to a more comfortable location, though I am not sure if that is your ideal solution.

EDIT: If you want to move your vessels, go to edit mode, select one of the ending vertices of a single vessel, and press O to enable proportional editing. In the proportional editing settings, enable Connected Only and then move your vessel to be farther apart from the other vessel to prevent intersection.enter image description hereenter image description here

$\endgroup$
6
  • $\begingroup$ Thanks for your time and your answer! The shown vessels will merge to one bigger vessel, so I can't move them separately. To specify, the vessels are "one part" so I can't select them separately. I already played with the offset and set it to the best possible position. $\endgroup$ Commented Jun 23, 2022 at 10:13
  • $\begingroup$ @hubbablender so did none of the solutions work? Not even the boolean modifier? Should have worked. Could you attach your .blend file so I can experiment in detail? $\endgroup$ Commented Jun 23, 2022 at 10:18
  • $\begingroup$ Hi, here is the download link for the .blend file. Thanks for your help! drive.google.com/file/d/14umaoBY9IiFQIIvOZvx_CwHi5gyjdwL5/… $\endgroup$ Commented Jun 23, 2022 at 12:03
  • 1
    $\begingroup$ @hubbablender Oh, I understand now. Check my edits in the "Moving your vessels slightly section", it will be your ideal situation I guess $\endgroup$ Commented Jun 23, 2022 at 12:06
  • 1
    $\begingroup$ @hubbablender if it solved your issue, kindly consider accepting the answer :) $\endgroup$ Commented Jun 23, 2022 at 13:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .