0
$\begingroup$

I have a slight shading issue as shown in the image below.

enter image description here

I tried to fix this with Shade Smooth, recalculating normals, etc, but to no avail. The problem persists when I view the model in 3ds Max.

enter image description here

Applying a Subdivision modifier in Blender or a TurboSmooth modifier in 3ds Max does help mitigate the problem, but it's still visible to the naked eye.

enter image description here

The mesh looks fine when I check it with X View in 3ds Max.

enter image description here

The issue becomes more apparent when baking a Normal Map as shown here:

enter image description here

Here is the Normal Map when baked in ZBrush

enter image description here

Unfortunately, the weird shading issue still shows up in a specular view.

enter image description here

It gets worse though when applying the baked normal map.

enter image description here

So my question is what causes this weird low poly issue, is there any way I can fix this, or is subdivision the only solution? And why does it affect the baking of a normal map? How to bake the perfect normal map? I tried baking normal maps in Marmoset and 3ds Max, but the issue persists in Blender.


Thanks a lot, Yousuf. I have tried your solution but unfortunately, it doesn't work in my case.

enter image description here

I did try Auto Smooth of up to 180 before

enter image description here

Here's the file:

$\endgroup$
6
  • 2
    $\begingroup$ hello could you please share the object? $\endgroup$
    – moonboots
    Jun 22, 2022 at 7:33
  • $\begingroup$ You could try auto smooth. $\endgroup$ Jun 22, 2022 at 8:31
  • $\begingroup$ thanks Duarte. And how delete the wrong answer I post myself . Its my first time here $\endgroup$
    – hk wing
    Jun 22, 2022 at 10:28
  • $\begingroup$ how to share my object,? moonboots $\endgroup$
    – hk wing
    Jun 22, 2022 at 15:11
  • $\begingroup$ share ur blend file at blend-exchange.com $\endgroup$ Jun 22, 2022 at 15:18

2 Answers 2

1
$\begingroup$

If you're talking about the smoothing, go to the Object Data Properties tab and enable Auto Smooth:

enter image description here

$\endgroup$
1
$\begingroup$

To me this looks like normal behaviour, your current topology is at the end of the day a low poly representation of what should be curved surfaces. Without the appropriate mesh density, the result is that you are not describing a smooth curve, but instead sharp edges. Smoothing the normals will just help hide the edges themselves, but if your faces are at a square angle, it's still a far stretch that smooth shading can't hide. You wouldn't expect smooth shading to make a cube look good? Well, it's the same here:

enter image description here

Furthermore, you have many quadrilaterals that have their diagonal vertices on a different plane, like this one:

enter image description here

And at the end of the day, you did shape your brow bone quite sharp, to begin with:

enter image description here

If that isn't your intention, maybe smooth the shape a little more. A quick sculpt pass with the smooth brush, and it will be gone.

All that said, this is expected from a low poly mesh. And the best way to fix that without compromising the low poly budgets is simply to bake a normal map from a higher resolution mesh that correctly describes the smooth curves of that area.

Just to give an idea of the difference, here's the result of your model with a normal map baked from a copy of that model with subdivision modifier level 2:

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .