Problem : Cloth intersect with avatar body when it's with cloth simulation.

So I try to change the cloth with sculpting mode frame by frame but I cannot edit it..

I baked cloth simulation and applied, but no change.

Any Ideas?

enter image description here

  • 3
    $\begingroup$ I'm not sure it's possible except with some convoluted methods, like you convert your cloth to a mesh at the frame where you want to edit it whereas you hide the simulation itself... Maybe the easiest way is to hide some parts of the body, or edit it? $\endgroup$
    – moonboots
    Commented Jun 22, 2022 at 6:42

1 Answer 1


I advise you not to use sculpting for this task, even if it is possible it is time-consuming and should make jittering effect.

Try to use Shrinkwrap modifier on cloth, Snap mode - Outside, target - the mesh body, increase Offset a little to start seeing the effect.

enter image description here

Another useful technique, that's highly recommended by professionals, is to hide everything that's not rendered.

In the body mesh, add all points that's normally hidden by dress into a new vertex group. Then set up the mask modifier like this:

enter image description here

Note that mask modifier is disabled in viewport for baking cloth and enabled in render to hide parts of the mesh that's may intersect with cloth.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .