1
$\begingroup$

I am trying to create a "reflection catcher", to work like a shadow catcher. I have followed this tutorial, which seems to work, but also seems to end up generating many more passes than I need.

I'm rendering as OpenEXR MultiLayer using Cycles, then compositing in After Effects.

These are my Layer Properties settings:

enter image description here

From the tutorial, I made three "View Layers":

  1. Main
  2. ShadowCatcher
  3. Reflection

My scene is an object to render, a tracked camera, a shadow catcher and a reflection catcher. The View Layers look like this:

enter image description here

In my render passes, I'd ideally only have:

  1. Combined pass of the object without reflections or shadowcatcher
  2. Shadowcatcher (to be Multiply composited in AE)
  3. Reflection Catcher (to be Screen composited in AE)

Instead I seem to be getting layers for all of my View Layers. What am I doing wrong?

$\endgroup$
4
  • $\begingroup$ Check this out: blender.stackexchange.com/questions/107757/… $\endgroup$
    – Crantisz
    Jun 21, 2022 at 8:37
  • $\begingroup$ Thanks! I saw this - but it's for a very old version of Blender. Is it still the best way to do it? (Also I'm getting a tonne of render passes because I don't understand how passes work properly) $\endgroup$
    – tomh
    Jun 21, 2022 at 8:37
  • $\begingroup$ Should be up-to-date. You can check this by getting the file $\endgroup$
    – Crantisz
    Jun 21, 2022 at 8:40
  • $\begingroup$ "I seem to be getting layers for all of my View Layers" Do you mean layers (that should be normal if you've selected the view layers for rendering) or that you get all selected render passes for each layer? Maybe you've added the additional layers with Copy Settings? Then all passes will be selected in all layers. $\endgroup$ Jun 21, 2022 at 8:43

0

You must log in to answer this question.

Browse other questions tagged .