2
$\begingroup$

The model I'm working with is a very high-poly .ply file with over 5.6 million faces.

Obviously, that's far too high, so I imported it into Blender and attempted to reduce the face count using the Decimate modifier. Using the default Collapse tab, I set the ratio to 0.011%, bringing it down to about 65k faces.

When it finished loading, the number of edges and vertices remained constant, and instead of reshaping the model, it had simply deleted most of the faces. It's like punching most of the windows out of a glass dome. I tried ticking the "triangulate" option, but that did nothing. I then tried using the Un-Subdivide tab, but raising the Iterations count to just 1 froze Blender, and it never responded even after 15 minutes of waiting.

$\endgroup$
5
  • 1
    $\begingroup$ here's how to decimate then use merge by distance. youtube.com/watch?v=Ek2QfKYmlOo $\endgroup$ Jun 21, 2022 at 1:50
  • $\begingroup$ @HarryMcKenzie Did as the video said. The problem persists. It's still just punching holes in the model, and Merge by Distance doesn't fill them. $\endgroup$
    – Dachimotsu
    Jun 21, 2022 at 2:54
  • $\begingroup$ sounds like a bug. can you attach the file? blend-exchange.com $\endgroup$ Jun 21, 2022 at 2:59
  • $\begingroup$ @HarryMcKenzie Upp, actually, someone on reddit figured out the problem. Turns out none of the polys were connected in the first place. So the steps you listed were the correct ones; I just had to do them in reverse order. $\endgroup$
    – Dachimotsu
    Jun 21, 2022 at 5:06
  • 2
    $\begingroup$ Hi. Please don't add "Solved" to your question or title. Instead we encourage you to post an answer below with a short description of the solution and what steps you took to reach it. Perhaps add a few images illustrating the workflow and final results. See How do I write a good answer? $\endgroup$ Jun 21, 2022 at 5:24

1 Answer 1

1
$\begingroup$

The problem was the original .ply files had no connected polygons at all. They were all separated. To fix this, I used "Merge by Distance" to fuse them all together, and was then able to decimate just fine.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .