4
$\begingroup$

I'm new in Blender and trying to hide a collection (CTRL+H), but the it keeps unhiding a different collection. I wonder how to fix this. Thanks! :)

$\endgroup$
6
  • $\begingroup$ maybe you have a collection inside a collection, it would explain why two collection get hidden when hiding one $\endgroup$ Jun 19, 2022 at 18:41
  • $\begingroup$ Thank you Pons, I have two separated collections inside the Scene Collection Imgur $\endgroup$ Jun 19, 2022 at 18:54
  • $\begingroup$ can you share the file? blend-exchange.com $\endgroup$ Jun 20, 2022 at 6:31
  • 2
    $\begingroup$ @HarryMcKenzie Not necessary, it's just a misconception of how Hide Collection is working (see my answer below). Unfortunately I haven't really found a documentation for this, and all shortcut lists I found on the internet seem to lack the Ctrl+H in Object Mode, they only list it for Edit Mode. $\endgroup$ Jun 20, 2022 at 8:05
  • 1
    $\begingroup$ thank you for this clarification! $\endgroup$ Jun 20, 2022 at 8:47

1 Answer 1

3
$\begingroup$

The shortcut key menu for Ctrl+H is actually labeled misunderstandably. It's not hiding the collection you click on, it hides all other collections except the one you click on - so it's more like "Isolate Collection". Your screen capture doesn't show that because you can only see objects there, no collections.

For example: I have four text objects, showing the numbers 1, 2, 3 and 4. Object 1 is in collection 1, 2 in collection 2, 3 in 3 and the 4 is in no collection (apart from the top level Scene Collection).

As you can see in the following screen capture, with the Hide Collection menu, always the collection I click on stays visible while all others are hidden. The number 4 which is in no collection stays visible all the time.

By the way, if you have selected an object, the dot to the left of the collection name indicates in which collection it is - in your screen capture you can see, when you click on the name with the dot, the selected tree appears. When you click on the other name, the unselected tree appears. So, the Hide Collection tool actually means: Select the collection you want to see and hide all others.

If you want to unhide all collections, go to the Outliner and press Alt+H. Note: this only works if the Display Mode of the Outliner window is set to View Layer (usually the default setting).

hide collection

$\endgroup$
5
  • $\begingroup$ Thank you for the answer Gordon! now it's clear why Blender hides the other objects. But unfortunately when I press Alt + H in the outliner nothing happens. Although I've moved my objects to the collections, the collections still empty as you can see on the screenshot Imgur $\endgroup$ Jun 20, 2022 at 21:09
  • 1
    $\begingroup$ @douglasfigueira Your collections are not empty (I guess). Your Outliner window's Display Mode is switched to Scenes, where the contents of your scene is grouped by datablock types, so it shows only collections under "Scene Collection", and all objects under "Objects". Switch the Display Mode to View Layer to see the default grouping: Outliner Display Modes $\endgroup$ Jun 21, 2022 at 5:48
  • 1
    $\begingroup$ @douglasfigueira The Unhide All option with Alt+H only works in the View Layer display mode. I've added this to the answer. $\endgroup$ Jun 21, 2022 at 6:37
  • 1
    $\begingroup$ @douglasfigueira If this helped you, would you mind accepting the answer? $\endgroup$ Jun 21, 2022 at 9:25
  • $\begingroup$ thank you now on View Layer mode is working great! $\endgroup$ Jun 22, 2022 at 1:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .