0
$\begingroup$

I'm trying to export a glass object in RGBA format. But the glass catches the HDRI colors in it and it's not transparent. And I wanted to use it to composite with another video so I need to be able to see through it.

Is there a setting that would turn that on/off?

Please see the example below: enter image description here

$\endgroup$
2
  • 2
    $\begingroup$ In the Render Properties under Film > Transparent you can find the option Transparent Glass to enable. $\endgroup$ Jun 17 at 6:20
  • $\begingroup$ @GordonBrinkmann could you add that as an answer to this post please? That is a relevant new feature worth documenting, in an attempt to keep old questions relevant and up to date following this discussion on meta. Feel free to add it here too for rep, and ping me in comments for upvotes. $\endgroup$ Jun 17 at 9:09

1 Answer 1

1
$\begingroup$

By default, blender does not have transparency in GlassBSDF node. You have to use TransparentBSDF node to give transparent property to your material.

Here is my node setup for Cycles enginemy node setup for Cycles

If you are using EEVEE engine. You have to change Blend Mode in material settings panel to Alpha Hashed or Alpha Blend (Alpha Hash will give some noise in renders. To render without noise, use Alpha Blend, but this would increase render time)

Here is my node setup for EEVEE enginemy node setup of EEVEE

Finally, to remove HDRI effects, disconnect any texture nodes connected to Background node in World Shader Node Editor

*To reduce background effects on the object, decrease the strength value.

enter image description here

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.