2
$\begingroup$

In my Viewport Solid Mode, I want to view items i'm adding to a plane via a collection as bounding box, but still view my terrain as "solid"

I have a plane that i'm creating a terrain via noise texture... then i'm adding a collection of items as "instance on Points"... but my computer is too slow, so I would like to see the items as bounding box.

If I go to "object properties" and change the viewport display to "bounding", it changes it for the individual items, but NOT for the ones added via the geometry node.

enter image description here

enter image description here

enter image description here

link to blend file: https://filedropper.com/d/s/7IYvbKPqWqMuAH2RHgfoPDXoDwYZ41

$\endgroup$
5
  • $\begingroup$ did you try to add bounding box node between collection and instance node? $\endgroup$
    – Chris
    Commented Jun 14, 2022 at 17:18
  • $\begingroup$ Somehow I cannot reproduce the behavior. When I switch the object containing the geometry node from Solid to Bounds, everything is displayed as a bounding box. The grid, the objects instantiated, everything, if I switch only the object in the collection to Bounds, only that is displayed as a bounding box. Can you share with us your blend file? $\endgroup$
    – quellenform
    Commented Jun 14, 2022 at 17:47
  • $\begingroup$ @quellenform I've added a link to the blend file with filedropper hope it works $\endgroup$ Commented Jun 14, 2022 at 18:16
  • $\begingroup$ @Chris the bounding box node after the collection seems to do the trick. thanks $\endgroup$ Commented Jun 14, 2022 at 18:17
  • $\begingroup$ @Chris but then it's annoying, I have to remove the bounding node and add it every time I want to render. I can't have it affect only the viewport $\endgroup$ Commented Jun 14, 2022 at 18:19

1 Answer 1

0
$\begingroup$

The problem here is the node Set Shade Smooth!

For some reason I don't know, it overrides the setting for Viewport Display.

If you just apply the node to the objects that are actually created in your geometry nodes, then it works.

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .