0
$\begingroup$

My laptop is Acer Nitro 5, intel i5 9300H, and GTX1650. Blender version is 3.1. GPU rendering setting is CUDA (screenshot). Nvidia driver version in 512.15, here is a detailed paste.

I downloaded the famous bmw blender file. With the charger unplugged, I opened the gpu blender file and clicked render, it renders the image perfectly.

Now this will drain the battery in no time.

Now, while rendering, if I plug in the charger, the rendering process crashes with the error,

Misaligned address in cuCtxSynchronize() (device_cuda_impl.cpp:1965)

Therefore I closed blender, Then I plugged in the charger, opened the bmw gpu blender file again, pressed render, this time also, I get the error,

Misaligned address in cuCtxSynchronize() (device_cuda_impl.cpp:1965)

I tried Optix setting too same result. I also tried blender 2.93, no dice.

What kind of sorcery is this? Why would my Laptop charging affect blender? How do I fix this?

EDIT : Solved on updating driver to 512.95 Still don't understand why charging affect GPU, power mode is already set to high performance with charger plugged in.

$\endgroup$
3
  • $\begingroup$ Maybe check your laptop's (windows) power management settings? It's possible (albeit unlikely) that your GPU accidentally got set to something like low power or even disabled when the charging cable is connected. $\endgroup$ Jun 13, 2022 at 3:39
  • $\begingroup$ Laptop is set to high performance with charger plugged in. $\endgroup$
    – User
    Jun 13, 2022 at 3:53
  • $\begingroup$ This might sound strange, but try rendering when in solid view in the viewport - other users have reported that the GPU renders as normal so long as the scene is not in Rendered Preview mode (all other preview modes work). Next step is a d river full uninstall/reinstall, making sure to stay at a certain version - see here - blender.stackexchange.com/a/208710/75504 $\endgroup$ Jun 13, 2022 at 11:41

0

You must log in to answer this question.

Browse other questions tagged .