0
$\begingroup$

So the issue I am experiencing is to do with the Select > Select All By Trait > Interior Faces command. From the description it claims to select faces where all edges of that face are touching more than two faces each. This is a very logical and efficient way of performing this task. However in my experience it appears to be failing more often than not as showcased in the gif below.

Relevant Information

  • I am currently using Blender 3.2.0
  • This mesh was created by vertex snapping a bunch of primitive cubes together in the same object.
  • I have executed the Mesh > Clean Up > Merge By Distance command to remove all duplicate vertices.
  • I have executed the Mesh > Normals > Recalculate Outside command to ensure all of the normals are correct.
  • All of my faces are facing the correct direction. They are all drawn in blue when viewed with the Face Orientation Overlay.
  • I have tried executing the Select > Select All By Trait > Non Manifold command as well but that does not solve my issue because it still selects additional faces that are not interior faces. I have also tried every setting available in the Non Manifold selection command.

Relevant Topics I have reviewed during my research of this issue

None of the solutions offered in these topics have fixed my issue and I believe that this may be a legitimate bug given my experiences with trying to use the command as well as other user's experiences trying to use the command.

Blender 3.2.0 Select Interior Faces Issue

Blender 3.2.0 Select Interior Faces Command Description

$\endgroup$

1 Answer 1

0
$\begingroup$

The one on the right works. But I had to align all the normals of the interior faces in the same direction (top and bottom).

enter image description here

This is with select All by Trait > Interior Faces

$\endgroup$
2
  • $\begingroup$ How did you flip them exactly? I flipped all of the face normals so that they were uniform on the top and bottom but I'm still getting the same result. Can you link to your fixed blend file? $\endgroup$
    – Tyler
    Jun 13, 2022 at 6:19
  • $\begingroup$ I will try to explain in more detail: 1) I selected all the exterior faces (using the views from the numpad: 1, crtl+1, 3... etc.) 2) I separated that selection (mesh > separate > selection or P+selection) 3) Then I aligned all the interior faces: mesh>normals>flip (as shown in the picture) 4) I joined both parts 5) Did a clean up > limited disolve 6) An another Clean up > merge by distance That fixed the issue for me. I forgot to unhide, so use alt+h in edit mod <img src="https://blend-exchange.com/embedImage.png?bid=zRJvbMev" /> $\endgroup$
    – Vagabonk
    Jun 13, 2022 at 7:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .