14
$\begingroup$

I can't delete rigid body cache from scene. When I delete old objects and add new ones they are acting like the old objects. I tried all options under rigid body cache panel in scene properties, Free bake, Bake All Dynamics and others but none of them is working. I wonder how can I delete old rigid body cache from scene?

$\endgroup$
5

3 Answers 3

6
$\begingroup$

Under the menu: Scene selection > Rigid Body World > Rigid Body Cache > Free All Bakes > Reset Start and End > Bake

This worked for me in 2.74. It took less than a minute to bake 325 frames.

$\endgroup$
3
  • 1
    $\begingroup$ This still does not work for me. Alt+A still produces old physics. So weird. But, 'Remove Rigid Body World' did $\endgroup$ Aug 21, 2017 at 2:50
  • $\begingroup$ Remove Rigid Body World under Rigid Body World works great if you are trying to clean up a file as well. I think this is the right answer. $\endgroup$
    – J Sargent
    Oct 23, 2018 at 13:47
  • $\begingroup$ In what panel do I find the menu: Scene selection? $\endgroup$ Jan 29, 2019 at 23:58
0
$\begingroup$

Just click on the "x" on the right side of the rigid body options in the physics

$\endgroup$
0
$\begingroup$

Actually, if cleaning cache doesn't work for you, I found it's easier to just change a few rigidbody properties, like mass or constraints threshold or whatever, that will let the rigidbody world recalculate the physics, at least for v3.4.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .