2
$\begingroup$

I have this object that is emitting hair particles. I must have done something to it that cause the hair particles to be emitted from the object's origin instead of being distributed evenly across it. This only happens to new particle systems, the one I made before this change on the same object is not affected. I'm wondering if anybody can tell me what I changed? I've been comparing it to an older version of the object that does not do this for a few days now and I can't see any differences.

What I get (after change) What I get What I want (before change) What I want

Just to clarify, if I change the location of the object origin like I did in the screenshot the hairs will always be emitted from the object origin. All new particle systems, even with default settings behave in the same way when used on this object. Particle systems that were created before the change on the same object are not affected. Particle systems on different objects do not behave in this way. To make it more confusing the 3D viewport only reflects this behavior seemingly randomly.

$\endgroup$
  • 1
    $\begingroup$ Could you upload your .blend file to Blend-Exchange? It would make it much easier to find out what is wrong. $\endgroup$ – VRM Mar 4 '15 at 14:58
  • $\begingroup$ I tried but when I hit "upload" nothing happens. Here is a stripped down version I put on my own server if you wanna have a look. hexagonsix.com/crap.blend $\endgroup$ – Galun Mar 4 '15 at 15:30
  • $\begingroup$ @Galun I'm the server admin, I'd like to know more about the issue? What size was the file, what happened when you clicked upload, and how long did you wait after uploading? Its working on my end. Do the steps in this demo match what you did: blend-exchange.giantcowfilms.com/help/Demo.gif? $\endgroup$ – GiantCowFilms Mar 4 '15 at 15:43
  • $\begingroup$ Yes, the only difference is I dragged it from KDEs dolphin file manager, and I tried to set a password. It gets to the point where it says "files may take some time to process", then nothing at all happens, the button just blinks when I click it. Nothing loads or indicate any activity at all. The file is about 37MB, and I waited for about 5min. Please make a site testing thread instead of trying to hijack mine, thanks. $\endgroup$ – Galun Mar 4 '15 at 16:01
  • $\begingroup$ @Galun You don't have enough rep to use the normal place we test, and no, the upload limit is 30MB, so that is excpected, I don't know why it let you upload it though? It should give an error. Apologies for hijacking your thread $\endgroup$ – GiantCowFilms Mar 4 '15 at 16:02
1
$\begingroup$

I just encountered this issue in blender and what I found out is than it is better to apply any modifiers, if you are using any, like the subsurface modifier. After i applied the modifiers the hairs vanished from the origin.

It is very important that you first remove the hair particle system from the object and then apply the modifiers, and then again apply the hair particle system.

I don't know for sure if this will work for you also, but better give it a try if you still have this issue.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.