4
$\begingroup$

I am trying to weight paint a mesh for a unity game, and only a few if any of the vertices are being painted. This is something I was able to do a while back in version 2.49, but now it doesn't work. This is also affecting my ability to vertex paint. I just reinstalled blender, and have taken a screenshot of me weight painting a subdivided version of the default cube(Without subdivision it wouldn't paint at all.), And it is clear that only a few of the vertices are being painted. I am trying to complete a model for a client and this has absolutely halted any forward progress. Help would be highly appreciated, Thank you.

[EDIT] OS = windows 7, gfx card = gtx 780ti. I have tried versions - 2.69(released 2013) through 2.73(released 2015) All fail.

enter image description here

$\endgroup$
  • 1
    $\begingroup$ the paint will apply only to the original vertices not the ones generated by the modifier(unless applied) $\endgroup$ – Chebhou Mar 4 '15 at 2:37
  • 1
    $\begingroup$ The subdivision was not done with a modifier. And I have come up with a temporary solution. If I completely remove the 3d viewport, by pulling the timeline over it. Then split the timeline into two, Turning the new window into a new 3d viewport all painting seems to work again. But I don't want to turn this into an answer incase somebody has a real fix and not just a work around. EDIT: so i was wrong, the new viewport fixed weight paint but not vertex paint. $\endgroup$ – Geoffrey Van Gieson Mar 4 '15 at 2:42
  • $\begingroup$ yes best leave it for more precise technical answer $\endgroup$ – Chebhou Mar 4 '15 at 2:47
  • $\begingroup$ does that happen in the default scene with the default settings , i'm using 2.73 and both paint are working fine $\endgroup$ – Chebhou Mar 4 '15 at 3:03
  • 2
    $\begingroup$ I doubt this is your issue, but one possible cause is that vertex weight painting respects vertices that have been hidden in edit mode-- a very handy thing for it to do, but it can be confusing if you don't realize that it's happening. (This is also true of sculpt mode, again, both useful and confusing.) $\endgroup$ – Nathan Jun 23 '18 at 7:34
0
$\begingroup$

Not sure if this will help, or if you have multiple bones, but the same thing happened to me and I was able to fix it when I discovered that the vertices that I couldn't remove had no weights from any other bone. After adding weight manually from other bones to the area, I was able to remove the weight from the bone I didn't want to affect the area.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.