3
$\begingroup$

I noticed in my last 2 blender files, that when i use subdivision surface, unwanted lines appear in quick rendering what is this? how can i fix that?enter image description here

$\endgroup$
  • $\begingroup$ What do you mean by quick rendering? $\endgroup$ – VRM Mar 3 '15 at 17:46
  • $\begingroup$ Maybe doubles in the mesh. Select all off it in edit and hit [Ctrl]+V > remove doubles. $\endgroup$ – Scalia Mar 3 '15 at 17:49
  • $\begingroup$ i mean when i use viewport shading as rendered. However, the lines are not there when i use Render button (camera icon) $\endgroup$ – FishBone Mar 3 '15 at 17:50
  • $\begingroup$ I just tried remove doubles, removed 0 vertices, didnt help, lines still appear in rendered viewport shading $\endgroup$ – FishBone Mar 3 '15 at 17:51
  • $\begingroup$ Blender Internal or Cycles render engine? Also, could you add a pic of your node setup/settings? $\endgroup$ – VRM Mar 3 '15 at 18:00
5
$\begingroup$

The problem is only present in orthographic view. Changing to perspective or a camera view will fix this problem.

It's also why the issue isn't present in the final render, because most of the time you will be rendering with a perspective camera. You can actually zoom into any mesh in orthographic view and small cracks will start to appear on the mesh.

It is a known issue, with the known issue page stating:

When using Instancing, Motion Blur or Dynamic BVH, self-intersection may occur due to precision issues. Switching to Static BVH may avoid some problems but not all

There are several bug reports mentioning that this might be improved in future here and here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.