3
$\begingroup$

I was following a procedural texture tutorial to make a texture for an object, but the bake is coming out a lighter color (I'm baking it to export it to a game engine). I've included the tutorials I followed along with screenshots of the difference between the procedural and baked texture.

Does anyone know what I need to do to make the procedural texture identical to the baked texture?

Skin texture tutorial: https://www.youtube.com/watch?v=HWo3jZ0dPII&ab_channel=RyanKingArt

Baking tutorial: https://www.youtube.com/watch?v=AioskAgcU2U&ab_channel=RyanKingArt

Model with procedural texture:
1

Model with baked texture:
2

Bake settings with light influence off:
3

$\endgroup$
4
  • 1
    $\begingroup$ it looks like it has to do with the Sheen value of the Principled BSDF, put it at 0 before the bake? Not sure why it's taken into account though. Also it looks like it's still not exactly the same in Material Preview but it works when you are in Rendered mode $\endgroup$
    – moonboots
    Jun 4, 2022 at 5:45
  • $\begingroup$ I would try connecting the image texture to the Emission output, set the Emission strength to 1, and then baking the Emit only. Diffuse might be taking scene lighting into account, while Emission will only take into account the values coming from the texture. $\endgroup$
    – Jakemoyo
    Jun 4, 2022 at 12:39
  • $\begingroup$ @Jakemoyo, if you disable Contributions > Direct and Indirect it should not take the lights into account, no? $\endgroup$
    – moonboots
    Jun 5, 2022 at 22:38
  • $\begingroup$ @moonboots Yes, I just find that Emission is the most straightforward way. $\endgroup$
    – Jakemoyo
    Jun 6, 2022 at 9:50

1 Answer 1

0
$\begingroup$

For anyone else having a similar issue, sheen is causing the issue. I set my sheen and specularity to 0 and it bakes correctly now.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .