0
$\begingroup$

I'm having some trouble with editing the geometry nodes added onto an object in Blender. The nodes work together to create a bridge, and it functions well, but at some point earlier today the nodes stopped being visible for the object in my node editor. Now, Blender treats the object as having no node editors on it, despite all the other telltale signs that the nodes are applied (there is a node modifier which is visible on the object, and beyond that the object still successfully looks like a bridge). This is what I see on my end in the node editor for the object. (https://drive.google.com/file/d/1YzQBA7pvmyTjRj_5topZ_93qArUmTud2/view?usp=sharing)

Troubleshooting has occurred but has been unsuccessful. I ensured that the "Use Nodes" checkbox in the shader tab was ticked, as I heard that was a resolution. I ensured that I was using the Eevee system, as that was also suggested. And I added a new "throwaway" node tree to the bridge object to ensure that nodes in general were still visible in the node editor; they were visib,e, but when I switched out the new throwaway node tree for the bridge node tree again the object disappeared entirely in the display (though the node tree was now visible). None of these troubleshoot options seem to resolve this issue.

If any of you could please take a look at this model and see what I'm missing here, I would greatly appreciate your guidance. https://drive.google.com/file/d/1_aYjNpWWxhKjRqi8jkpQMIir8x_L8mlZ/view?usp=sharing

TL;DR - I want to make edits to the geometry nodes on a bridge, but the node editor is not properly displaying the bridge's nodes. https://drive.google.com/file/d/1_aYjNpWWxhKjRqi8jkpQMIir8x_L8mlZ/view?usp=sharing

$\endgroup$
2
  • 1
    $\begingroup$ did u select the GN modifier in the right list? I had this problem in the beginning often too....you have to select it to see it. And if you think about it...the behaviour even makes sense 😉 $\endgroup$
    – Chris
    Commented Jun 3, 2022 at 4:00
  • $\begingroup$ so after downloading and selecting, i see : [1]: i.sstatic.net/RVkCf.jpg $\endgroup$
    – Chris
    Commented Jun 3, 2022 at 4:01

1 Answer 1

2
$\begingroup$

Just select the GN modifier in the list, then you will see it. This behaviour actually makes sense because you can have several geometry nodes modifiers.

$\endgroup$
3
  • 2
    $\begingroup$ You can also enable the little pin button to make the editor show a particular node tree, instead of switching with the selected object/modifier. $\endgroup$
    – user436
    Commented Jun 3, 2022 at 9:56
  • $\begingroup$ Yes, good hint! $\endgroup$
    – Chris
    Commented Jun 3, 2022 at 9:57
  • $\begingroup$ Thank you for your answer! Unfortunately, whenever I tried selecting the appropriate node tree (either in the geometry node editor or in the geometry node modifier), the node tree would remain invisible in the node tree editor. I did find a solution, however: I had placed a collision modifier after the geometry node modifier, and that seemed to prevent further edits to the node tree (which makes sense, of course). Removing the collision for now seems to have resolved the issue. Thank you for helping me dig for a solution! $\endgroup$ Commented Jun 3, 2022 at 13:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .