9
$\begingroup$

When I import a movie clip into Blender's VSE, I match the resolution and framerate (1288 x 1032 at 25fps in this instance) and the audio and video strips appear to match up in the display. With AV-sync, the audio and video appear to playback in VSE in sync.

Unfortunately the rendered video file seems to be playing video at twice the speed of the audio (while at the same framerate, 25fps).

Why is Blender outputting a file with a video track playing at twice the speed that it was imported? I am trying to reduce the size of the video's resolution - could this have an effect on it?

OS: Microsoft Windows XP Pro (5.1) MOTHERBOARD: Gigabyte P35-DQ6 CPU: Intel Core2 Quad CPU MEMORY: 2046MB RAM DIRECTX: Direct x 9.0c GPU: NVIDIA GeForce GTX 560 Ti

An image of my Blender import/output settings with the VSE can be found at the following link, along with sync test .avi I'm using to test this problem and a rendered example of the test, showing the problems I'm having - https://www.dropbox.com/sh/1pgn7l1sz7l8uz1/C6UHBBTdO0

Currently enjoying Sebastien Konig's Match Track Blend DVD and this little problem is an annoying distraction. I look forward to getting back on track. =)

Thanks in advance,

--Rev

$\endgroup$
  • $\begingroup$ It may be a codec problem. What are the original footage video & audio codecs ? $\endgroup$ – Polosson Aug 31 '13 at 9:15
  • $\begingroup$ The syncTest01002Rev video is MPEG-4 Video (XVID). The exported video is MPEG-4 Video (FMP4). The original video that I encountered this problem on (while following Match Track Blend) was the Sintel Trailer encoded in H264-MPEG-4 AVC (part 10)(avc1). Thanks for the inquiry, I'm somewhat at sea here. $\endgroup$ – Reverend Speed Aug 31 '13 at 9:33
2
$\begingroup$

I loaded up your syncTest01002Rev.avi file and playback wasn't in sync. Inspecting the file with ffmpeg gets the following message: "[mpeg4 @ 0x19ecc00] Invalid and inefficient vfw-avi packed B frames detected". Re-encoded to fix the error, when loading into blender, it had an extra frame (680) and worked without issue.

$\endgroup$
  • $\begingroup$ Thank you for your time and suggestions. The sync test was recorded with CamStudio - would you have any suggestions for how to avoid such errors in future? In order to fix my sync test, should I use ffmpeg? Are there any tutorials about this you can recommend? Again, many thanks. $\endgroup$ – Reverend Speed Aug 31 '13 at 12:36
  • 1
    $\begingroup$ You'd get best performance and end quality if you recorded to a uncompressed (preferably lossless) format. I'm not a Windows user so can't recommend specific settings or other software to use (try over at superusers for suggestions). $\endgroup$ – Aldrik Aug 31 '13 at 14:23
  • $\begingroup$ Will do. Sorry for the delay in responding. Import and export in Blender seems to be working perfectly for all videos... except for the video I made specifically to test the import and export functionality in Blender. So it goes. $\endgroup$ – Reverend Speed Sep 4 '13 at 15:53
1
$\begingroup$

I had this same problem and fixed it in Blender after I observed the original video resolution that I had was different than the one set in Blender properties. After right clicking the video segment to highlight and clicking "Strip" then "Set render size" which then corrected the property value on Blender to match the original video data it all synched perfectly. Here's where I got the info from: https://www.youtube.com/watch?v=Boql0WIQqlA&list=PLjyuVPBuorqIhlqZtoIvnAVQ3x18sNev4&index=4

Check the 2 min mark for info to this specific issue. Good luck

$\endgroup$
  • $\begingroup$ I don't have time to test this, but the information and link look like they're relevant. Will upvote, but can't mark as correct atm. $\endgroup$ – Reverend Speed Oct 15 '15 at 15:48

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.