0
$\begingroup$

I am trying to create a very simple example where I set a force field on an empty to simulate Earth's gravity. The scenario consist on:

  1. a cube, with rigid body enabled (active), set at an altitude of 10m.
  2. a plane, with rigid body enabled (passive), set at the origin (0m).
  3. an empty, set at a position (0, 0, -R_earth), and with a force field attached to it. The force field has a "strength" of -3.986e+14 and has the gravitation label activated (multiplying the resulting force by the inverse of the squared distance).

One would expect the cube would drop in around 1.428s (at least its centre of mass), but it just doesn't. I am aware that Blender is not perfectly transparent when it comes to physics, but there is the possibility that I am doing something wrong with the fps of the simulation (or the rendering of the simulation), or something else.

I attach the .blend file here so you can see what I am playing with and maybe find out what/if I am doing wrong.

Thanks!

$\endgroup$
2
  • $\begingroup$ blend file: we.tl/t-yBqWYpzyV8 $\endgroup$ Commented Jun 2, 2022 at 16:14
  • 1
    $\begingroup$ blender physics is pretty great, but not perfect. And setting any value in Blender to very low or very high numbers like e+14 will make trouble - at least because of rounding issues. So i would try to work with a force field nearby and try out the strength until it falls as you want it. Blender is definetely not a real world physics simulation... $\endgroup$
    – Chris
    Commented Jun 2, 2022 at 16:38

1 Answer 1

1
$\begingroup$

I'm totally wrong person to give you some serious advice here ... so just a few notes:

  • Speaking to @Chris's comment - using microscopical or astronomical numbers causing a lot of problems in Blender. Not only in simulation, but mainly with viewport display ...

Here when you try rotate your Empty object :)

enter image description here

So instead try under Scene Properties > Units > Units Scale ... 1.000.000

enter image description here

It should be connected with general Blender's Gravity, but I'm not sure about Rigid Body World. You would have to test it.

Edit: I just noticed ... you would be trapped since you are in astro scale, but you want to see a cube in 2 m dimension is like micro. Empty is fine, but now the Cube has a problem :)

enter image description here

In this place is probably good to ask you why do not use default Gravity parametr instead of Force Field.


  • Another thing is, if you really need to place Empty > Force in the center of Earth? From my previous test with Fluid it worked just placed at ground level with Strenght -9.81 ... that is not working at the moment for me with default Cube.

enter image description here

I had to increase under Scene Properties > Rigid Body World > Settings > Speed up to 17 to match blender's Gravity fall time 1.10s ... that doesn't make a sense to me. So there seems to be something wrong.

enter image description here Tip: Gravity parametr in blender can be disabled for whole scene in Gravity tab or just for RBW under Field Weights

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .