1
$\begingroup$

I imported a character (with append), and I joined the hair, body, and feet together using Ctrl+J. I applied the scale, rotation, and location using Ctrl+A, and everything was fine, and when I generated the rig, it worked perfectly. However, now that I've skinned the mesh, half of the character has disappeared. Here are some screenshots:

Before skinning:

enter image description here

After skinning: enter image description here

$\endgroup$
  • $\begingroup$ I think with rigify you need to parent and weight paint to the basic mesh before you generate the final rig. $\endgroup$ – sambler Mar 3 '15 at 7:08
  • $\begingroup$ Could you upload and link the .blend to your question blend-exchange.giantcowfilms.com ? $\endgroup$ – stacker Mar 3 '15 at 8:18
2
$\begingroup$

I've fixed the problem. After some research on the 'net, the solution that worked for me was to enable Auto Run Python Scripts in File > User Preferences.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.