1
$\begingroup$

I am trying to lay a cloth over the top of an square ring, but it behaves strangely. I enabled collision for all of the planks that make up the rim of where the cloth lands, and I have applied a subdivision modifier and a cloth modifier to the cloth, which is a plane that I have scaled up. I have tried increasing quality for both the cloth and the collision to no avail. I have also tried subdivision from 1 to 8, with no difference in result. I have also played around with the Tension/Compression/Sheer/Bending stats for the cloth. I have also reset the scale of the sheet.

The first photo is the edges consuming the cloth

The second photo is the structure under the cloth

The third photo is the mid-fall beginning to gravitate toward the boards at the edges. It doesn't fall like the rest of the cloth, but is instead sucked down onto the board. I'm sure this is a side effect of the problem I am having.

Blend file:

The cloth is being consumed by the boards holding up the edges

$\endgroup$
5
  • 1
    $\begingroup$ What is your collision setting? And would you provide the .blend file here: blend-exchange.com $\endgroup$ Commented Jun 1, 2022 at 9:43
  • $\begingroup$ At what distance is your cloth falling from? Decreasing the distance would also help. $\endgroup$ Commented Jun 1, 2022 at 9:59
  • $\begingroup$ @ChaudhryYousuf - Thank you for the help! I applied some of the changes you recommended and it got a little better, but the planks are still "eating" the cloth. I have attached the blend file to the question as per your request. Could it have something to do with the normals of the planks themselves? It seems like there is something wrong with the actual surface of the planks. Thanks again! $\endgroup$
    – Hixtra
    Commented Jun 1, 2022 at 16:48
  • $\begingroup$ Hmmm... Wait, let me try and see if I can fix it still. $\endgroup$ Commented Jun 1, 2022 at 17:32
  • $\begingroup$ Check my edit on my answer. It will fix the problem, it did it at my end when I tested it on your file. $\endgroup$ Commented Jun 1, 2022 at 18:07

1 Answer 1

1
$\begingroup$

Decrease the distance between the cloth and poles before simulating. Then, under collision on the cloth object, increase the quality to something like 10 or 15. Also, don't forget to enable self collisions.enter image description here

The problem in mid simulation might be because it's the first part to touch the poles/there might be a problem in the vertex group you used as a pin group. On the collision settings on your poles decrease the thickness outer value to something like 0.001 to improve the quality of the simulation. On the cloth object, try increasing the quality steps on the top to something like 10. You can also try reducing the vertex mass if you want.

Edit: I think I found the solution after testing on your file. On each of the side sticks (the rectangular ones connecting the poles) disable single sided. Add a subsurface modifier above the cloth modifier with a level of 2 or 3. If you want to, you can also add a solidify modifier above the cloth modifier. Increase cloth quality steps to 20 or 25 (subsurface level 3 would be best) and collision quality to something like 40 or 50. Go even higher on all these settings if it still intersects slightly. The higher the quality steps/collision quality/subdivisions in the subsurface modifier, the more accurate your simulation will be.

$\endgroup$
2
  • $\begingroup$ Fantastic! These settings have solved the problem. Thanks for the help! $\endgroup$
    – Hixtra
    Commented Jun 1, 2022 at 19:18
  • $\begingroup$ No problem! I hope you have fun with your project. $\endgroup$ Commented Jun 1, 2022 at 19:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .