1
$\begingroup$

initially i wanted a cylinder shaped tank be filled with liquid. so i followed this tutorial:https://www.youtube.com/watch?v=3ud6Hozy0vw&t=315s it basically goes as: flip the normals - put the generator inside the tank - boolean the domain so the fluid doesn't come out the edge. mine still flushes out the effecter(the tank) within the domain. so i did it over several times and each time comes with all different kinds of problems...

and then since there're so many basic water tap fluid simulation tutorials on youtube so i changed to another solution to get what i want so i separate the top face of the tank as a flow, the tank as a effecter, and a domain. then now i couldn't even get any water out of it...(the normals doesn't need to be flipped in this case right?)

besides, as soon as i changed the domain to liquid mode, the wire became into a solid cube... is that normal i don't think so? the solid also shows when i add shades on it..

(basically i just want a tank 3/4 filled with oil-textured fluid and it looks so easy and organized theoretically...)

thanks!!

here is my solid domain cube.....i don't think i've baked it..

$\endgroup$
1
  • $\begingroup$ Hi Please use a title that reflects the content of the question. It should be descriptive but succinct, unique and identifying, summarizing the issue so that users can at a glance understand what your post is about. Use the edit link below your post and avoid anything not strictly essential to the post. Remember, your title is the first thing potential visitors will see, and makes your question findable for future users. See "What is the problem with posting an image or link and asking “How do I do this?"" $\endgroup$ May 31, 2022 at 22:24

2 Answers 2

0
$\begingroup$

I don't know what’s the problem with your current file but you could copy paste the 3 objects in a new file and:

  • Scale the domain a bit and apply its scale, in the fluid panel, increase the Resolution Divisions, enable the Mesh option
  • Put the origin at the geometry of the 3 objects
  • Disable the fluid Is Planar option of the effector, add topology (circular loopcuts), and give it thickness with an extrusion along normals (make sure that the normals are still correctly oriented)
  • Thicken the inflow a bit on Z in Edit mode
  • At last select the domain and under Cache > Type > choose Replay
$\endgroup$
0
$\begingroup$

The 'type' option in the physics 'Fluid' seems to differ between 'ver 2.81' and earlier and 'ver 2.82' and later, with only 'domain, flow, effector, none' (from the Blender Manual). On the 'projects.blender.org' website. 'Incorrect obstacle behaviour in fluid simulation #101304 (https://projects.blender.org/blender/blender/issues/101304)' I hope this is helpful for your query.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .