6
$\begingroup$

I have a cloth simulation where I'm trying to get a plane object to deform correctly over a bent cylinder. It seems no matter what I change it always goes through the mesh slightly, on the surface. This is a simple version of my project, it's even worse when things get complicated. Modifiers don't seem to affect the problem either, nor do quality steps of the simulation or collisions and I can't seem to find any similar situations with any logical solutions. Does anyone know why this keeps happening? I've attached a screenshot as well as my blender file. enter image description here

$\endgroup$
2
  • $\begingroup$ there is no blend file... $\endgroup$
    – Chris
    May 29 at 3:13
  • $\begingroup$ @Chris i apologize, there is now. It takes some time to upload $\endgroup$
    – Spring
    May 29 at 3:17

3 Answers 3

7
$\begingroup$

To add to Chris' answer, you also need to apply the scale of your objects and change the collision Distance of the cloth. As your object is pretty big, choose a value of 1 for example, then delete the bake and bake again:

enter image description here

$\endgroup$
6
  • $\begingroup$ Both answers make logical sense, and I thank you for this one, but again, it doesn't seem to have fixed my problem, I'm pretty stumped, i have no idea whats wrong with my model/blender. $\endgroup$
    – Spring
    May 29 at 8:21
  • $\begingroup$ I'm using your current file, I've just changed the modifiers order and also applied the scale and changed the collisions Distance, and as you see it seems to work $\endgroup$
    – moonboots
    May 29 at 8:29
  • $\begingroup$ oh also don't forget to delete the bake and bake again ;) $\endgroup$
    – moonboots
    May 29 at 9:34
  • $\begingroup$ I've retried this and Chris's answer combined with yours does in fact work for that setup, I'm still trying to get it to work on another but that isn't a problem for this post ofc! Which answer do you suggest I accept-? $\endgroup$
    – Spring
    May 29 at 9:48
  • 1
    $\begingroup$ I think I'll accept Chris's since it did provide the most information, though I do appreciate your answer immensely, it was very necessary, and anyone reading this later should be able to tell that both answers were needed in unison, from the comments! $\endgroup$
    – Spring
    May 29 at 9:55
8
$\begingroup$

you should change the order of your modifiers. The solidify modifier should always be after the cloth modifier to "repair" the little inaccuracies.

So i used these modifier settings:

enter image description here

with this cloth settings:

enter image description here

enter image description here

and i got:

enter image description here

enter image description here

$\endgroup$
1
  • $\begingroup$ I'm afraid after adding all these exact modifiers, in that order, as well as changing the cloth settings didn't seem to fix the problem. I suppose I should've made it more clear that no matter what modifiers, in what order, it still seems to have this problem. Thank you for your effort though, i just don't understand why all my versions of blender seem to be so broken when it comes to cloth, or if I'm doing some abomination I'm unaware of, I'd like to know. I've been using blender a long time but I'm quite new to cloth simulation, so it's certainly rather frustrating to try to debug this. $\endgroup$
    – Spring
    May 29 at 5:39
1
$\begingroup$

The issue comes from the offset of the Solidify modifier, change it from -1 to 1 (like Chris did). And set Collisions Distance to 0.01 (I did that and works fine).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.