8
$\begingroup$

I have Blender 2.49b and have this mesh:

Front:

front side

But on the back the mesh is transparent:

back side

How to fix this?

$\endgroup$
  • 2
    $\begingroup$ "I have Blender 2.49b" well there's your problem. Are you having trouble upgrading? $\endgroup$ – wchargin Aug 30 '13 at 17:07
  • $\begingroup$ :D 2.49b Blender is good compatilible with export to DirectX for working in a game.. :D P.S. Its a not bug of Blender.. $\endgroup$ – GAMELASTER Aug 30 '13 at 17:52
  • $\begingroup$ I don't know where this is in 2.49b, but try disabling "backface culling" $\endgroup$ – gandalf3 Aug 30 '13 at 18:13
  • $\begingroup$ I finded it, but its only flip it [in front side is a transparent] $\endgroup$ – GAMELASTER Aug 30 '13 at 18:25
  • $\begingroup$ @GAMELASTER then you might have to make it have some thickness. (I don't know if 2.49b has the solidify modifier, but you might be able to just extrude it) $\endgroup$ – gandalf3 Aug 30 '13 at 18:30
4
$\begingroup$

2.49b:

Try adding some thickness to your mesh.

It seems to be currently a 2 dimensional plane, which will only have one side drawn unless double sided faces is enabled.

2.6x:

It seems that double sided faces was removed in 2.6x.
Backface culling can also cause this. The Backface culling setting is located in 3D view > Properties panel > Display:

enter image description here enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ In 2.5x Double Sided was moved to Mesh Properties under Normals. The backface culling option was added in 2.64 but the back of the poly should be visible in solid mode, it's only textured mode that hides the backface. $\endgroup$ – sambler Aug 31 '13 at 4:12
  • $\begingroup$ @sambler thanks :) fixed. (though backface culling does seem to effect the mesh in solid view?) According to this, double sided normals is not the same as double sided faces $\endgroup$ – gandalf3 Aug 31 '13 at 19:18
  • $\begingroup$ backface culling will make the back transparent in solid and textured mode(2.64+). 2.49 that GAMELASTER is using doesn't offer that so textured mode or texture solid should be the only time it is transparent. $\endgroup$ – sambler Sep 1 '13 at 4:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.