0
$\begingroup$

enter image description here

With auto smooth on, the shading is weird

enter image description here

without auto smooth , its clean enter image description here

$\endgroup$
4
  • 1
    $\begingroup$ you should show us your topology.... $\endgroup$
    – Chris
    Commented May 21, 2022 at 8:51
  • $\begingroup$ could you please share your file (the part you show only): pasteall.org/blend $\endgroup$
    – moonboots
    Commented May 21, 2022 at 9:23
  • $\begingroup$ try to make a mesh with all quads. $\endgroup$
    – X Y
    Commented May 21, 2022 at 9:47
  • $\begingroup$ @XY dont be hating on the triangles :) $\endgroup$ Commented May 21, 2022 at 10:26

1 Answer 1

3
$\begingroup$

In the Object Data Properties panel, under the Geometry Data tab, try using the Clear Custom Split Normals Data. I am still not sure what it does, but it works for me sometimes.

Clear Custom Split Normals Data option under Geometry Data

Hope this helps !

$\endgroup$
2
  • 2
    $\begingroup$ It removes any custom normals data. The normals for faces are usually calculated from the geometry of the face, so that they just point outwards - but blender is happy to let you overwrite them with normals pointing in arbitrary directions. Typical sources of this include using the bevel command with Harden Normals, applying a Weighted Normals modifier, painting the normals or really anything that manually or automatically modifies normals! Clearing it like you suggest resets it to calculated from the face and edge angles. $\endgroup$
    – Ben
    Commented May 21, 2022 at 9:59
  • $\begingroup$ Aahaa ... I didn't know here were so many ways to override the normals directions! Thanks a lot for the clarifications... :) $\endgroup$
    – Adisage
    Commented May 22, 2022 at 10:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .