2
$\begingroup$

I tested this simple setup where i created a 4x4m cube and created a 1m radius hole using boolean operation with a cylinder. So now i have tightly fit in the exact cylinder i used to make the hole and I've also reduced the radius of the cylinder by 0.05m with ALT+S to create this decent-sized gap as shown in the image below. Unfortunately it seems that this is not enough because the physics doesn't work. It keeps vibrating as if they are constantly in a state of violating the physics law of impenetrability. It does work if i decrease the cylinder by another 0.05m but that is way too big of a gap. I need the 2 objects to be as tight together as possible. How do i do that? I'm using collision shape mesh and tried all sources (final, base, deform) but unfortunately nothing works. I also checked the face normals orientation and it is correct; all faces are blue. File is here https://blend-exchange.com/b/ddzxasdA

enter image description here

$\endgroup$

1 Answer 1

4
$\begingroup$

When you choose Collision Shape > Mesh, the Rigid Body automatically uses Sensitivity > Margin with the default value of 0.04 whereas different shapes like Box or Convex Hull etc. have no default margin. There you have to enable Collision Margin to use a margin value.

If you set the margin to 0.0 on both objects, the simulation should become more stable. For even better results (but of course more to simulate) you could also increase Solver Iterations and maybe Substeps Per Frame under Scene Properties > Rigid Body World > Settings.

collision margin

$\endgroup$
5
  • $\begingroup$ yes thank you very much! i just remembered this sensitivity option after i posted and went to the bathroom hahaha XD sorry $\endgroup$ May 18 at 5:57
  • 1
    $\begingroup$ @HarryMcKenzie You're welcome, hopefully this still helps others. It's really not that obvious especially for beginners I guess, that rigid bodies have turned off the margin by default if you use any other shape than Mesh, and there it suddenly is. Most beginners make the mistake of using Convex Hull where maybe Mesh is needed, and if they are just told "switch to Mesh instead" without pointing out that margin detail, they can suddenly run into new problems which they didn't have before. $\endgroup$ May 18 at 6:02
  • $\begingroup$ sorry i forgot to ask about the fall impact. it works on the fall but on impact it seems to not work though no matter how low or high i make the steps & iterations, it explodes on impact with margin 0 or 0.01. $\endgroup$ May 18 at 6:12
  • 1
    $\begingroup$ @HarryMcKenzie I've set both objects to a margin of 0, then I go to cache, delete all bakes, then bake, and nothing explodes. Without changing any iterations or substeps, they are at default 10. Here's my updated file: fail-physics_new.blend Which version of Blender are you on? I'm using 3.1.2 $\endgroup$ May 18 at 6:26
  • $\begingroup$ cool thank you very much! :) $\endgroup$ May 18 at 14:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.