0
$\begingroup$

For some reason, the X and Y axes are mixed up in Pose Mode. When I move the bone along the X axis, the values Y change, when I change along Y, they change along X. In the Grapth Editor, the axes are even worse mixed up, changing X changes Z, changing Z changes Y, changing Y changes X. How to fix it?

P.S. I read the explanation that the axes are indicated in relation to the bone itself, but this only confuses and interferes with me. I would be happy to know how to turn off the orientation from the bone and use only the global, normal where XYZ is always XYZ

$\endgroup$

2 Answers 2

1
$\begingroup$

The section of this question after "P.S." is your answer, unfortunately. You cannot 'turn off' local axes to the best of my knowledge, as this is a fundamental function of how 3D objects work.

If you had for example, a fighter jet, you'd want to have its local axes stay consistent so that, say, the Y axis is not only always the pitch rotation of the craft, but also so that the Y axis perfectly lines up with the craft. If you were animating a scene like this, you'd want to work in local space - it would get messy otherwise because you might be trying to steer the jet along a vector that's somewhere between two (or three) axes.

If the situation calls for it, there's nothing stopping you from working purely in global space, but you need to be aware of every object's own local axes.

$\endgroup$
0
$\begingroup$

While Onyx' answer in that the bones use their own space independent of the world space; there's a bit more complexity to that:

Out of the box, Blender's bones are in Yup coordinates system, and Blender uses the bones' local axes, but taking into account whatever rotation you have in the rest pose, and independently of the rotation in pose mode.

Let's take a simple default bone for example. If we enable the armature object's Axes in the Viewport Display panel, we see this:

enter image description here

In this case, if we use the default worldspace gizmo to move "up", which is +Z, we would see the bone's Y location getting change. Because the worldspace +Z is his +Y.

Now, if you rotate that bone -90 on its X axis, you obtain this:

enter image description here

At this point, moving the bone up would still change its +Y value. But if you hit ⎈ CtrlA → Apply Pose as rest pose, now moving the bone up will change his +Z:

enter image description here

In other words, if you want your bones to use any coordinates' system, you need to set it up before animating, either while making your rig in edit mode (recommended) or from the pose mode by applying the pose as your rest pose (which WILL break any animation already done, and might also break your rig depending on how it is made).

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .