1
$\begingroup$

About a month ago I made the switch from blender 2.8x to 3.1 but I've noticed that double clicking an item in the Outliner no longer brings up the renaming bubble, so in order to rename something I HAVE to press f2 every time.

Up until now I have just been dealing with it, but now I have an old project that I'm updating and I have a whole human rig, fingers and all that needs manual renaming.

Even so, having to press f2 to rename things in the outliner nearly triples the time it takes me to manually rename things!

I have tried to use the batch rename function, but no matter what option I pick it just wont work for bones, despite there being an option under "type" for bones. This option wont even select!

Is there any way to make it so you can double-click rename again? This problem only seems to apply to the outliner.

I am using Windows 10 Home

$\endgroup$
1
  • $\begingroup$ Double clicking works for me in 3.1 - something else must be going on. $\endgroup$ Commented May 17, 2022 at 0:53

1 Answer 1

2
$\begingroup$
  1. Go to Keymap > Outliner
  2. Press Add New
outliner.id_operation
  1. ID Data Operation change to Rename

enter image description here

$\endgroup$
2
  • $\begingroup$ Thank you thank you! Yes this was exactly the fix I needed, it worked right away! $\endgroup$
    – Krayne
    Commented May 17, 2022 at 5:10
  • $\begingroup$ @Krayne Since you're apparently a new user to Blender StackExchange, you might want to read What should I do when someone answers my question? and perhaps upvote or accept this answer $\endgroup$ Commented May 17, 2022 at 16:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .