0
$\begingroup$

I've recently realized that the videos I've rendered using the 2.8+ VSE are much more choppy than they should be.

For example, in this animation, there are supposed to be 11 frames total that should play in the animation. Frames

However, when I render the frames in the VSE, the output video only has six frames. The animation still contains the start and end frames, but several throughout the animation are missing.

These animations are very short and are designed to be transitions for my game, so it's important they be smooth. I designed them to be 11 frames running at 30 fps, but the video output is just 6 running at 30 fps, and the result is not smooth enough.

Here is part of my setup. enter image description here

And here are my video output settings enter image description here

What's odd is that in the VSE preview, the animation is smooth and has all of its frames, but not when rendered.

Is it because of my video output settings? Does choosing "perceptually lossless" mean the VSE cuts some of the frames? I would think it would just compress each image a certain amount, not get rid of some of them.

Or is it encoding speed or something else?

$\endgroup$
4
  • $\begingroup$ In my experience PL is THE BEST export setting to use in VSE $\endgroup$ Commented May 13, 2022 at 22:26
  • $\begingroup$ Does PL usually cut frames from the final video? $\endgroup$ Commented May 16, 2022 at 0:45
  • 2
    $\begingroup$ You seriously need to upgrade your Blender version. $\endgroup$
    – tintwotin
    Commented May 17, 2022 at 6:34
  • $\begingroup$ @tintwotin What do you mean? I'm using Blender 2.92, that should be current enough. $\endgroup$ Commented May 19, 2022 at 23:26

1 Answer 1

2
+100
$\begingroup$

Should be a bug. This is what I've found:

Blender 2.93, container AVI - file displays wrong

Blender 2.93, container MP4 - file displays correct

Blender 3.1, container AVI - file displays correct, but file generated by 2.93 displays wrong

All other settings match yours

But again it looks like playback issue, file itself looks correct. I think I've reported something related in the past https://developer.blender.org/T86944, so consider updating the Blender as tintwotin suggested.

If the version is important for you - try to use MP4 container with the same codec.

$\endgroup$
2
  • $\begingroup$ Thank you, it actually worked, my video file output by using v3.1 and .avi displays all the frames! I thought 2.9 would've been current enough, but I was wrong. $\endgroup$ Commented May 23, 2022 at 22:16
  • $\begingroup$ 2.82 should be good also, it was a bug around 2.92-2.93 versions $\endgroup$
    – Crantisz
    Commented May 24, 2022 at 8:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .