2
$\begingroup$

I understand that in the Blender Game Engine, the GLSL shading mode is generally suggested, because it renders real-time shadows, and it renders per pixel instead of per vertex like in the Multitexture shading mode. I noticed that when I switch to the GLSL shading mode, materials, and textures don't show up in the internal player, and it appears as if all materials have been set to shadeless. If I use the Standalone Player button, it displays all the materials and textures properly. I'm curious if there is a setting that I should have checked, or if it is normal for this to happen. Also, once I package my game, will it appear as if it's running in the Standalone Player, or the internal player? Thanks so much for your help.

$\endgroup$
5
$\begingroup$

Setting the Viewport Shading to 'Textured' should help with this. 'Material' also works.
It sounds like you may be using 'Solid' mode.

enter image description here

$\endgroup$
  • $\begingroup$ I find it interesting that the Embedded Player display will be different depending on the viewport shading. I guess it makes it easier to debug in different situations. Thanks so much for you help! $\endgroup$ – Anson Savage Feb 27 '15 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.