1
$\begingroup$

What am I doing wrong, where it states "RH" in the RH Alleyway compositor group, there is a wall which should cut off the white circular highlight, for testing purposes I have cut off the circular highlight even more in the image editor with the mask drawn, yet in the compositor nothing is happening. I want to use the mask to subtract from the image (or alpha channel) so it cuts off. This mask will need to be animated or assigned to a track marker to keep the wall occluded by the one in front of it. enter image description here

Edit 1: I have also tried a set alpha node and plugging the mask into that and it also doesn't have any effect on the layer.

Edit 2: So I managed to get the following mask test working:

enter image description here

The next question is how do I plug it into the full comp, no matter how i've connected it, the circular highlight still shows in full, or not at all, below is how it is at the moment unconnected under the RH Alleyway group:

enter image description here

$\endgroup$

1 Answer 1

0
$\begingroup$

Alpha Over allows you to layer B over A using either B's own alpha, or C as an alpha:

enter image description here

Whereas Set alpha will allow you to set the alpha of B using C:

enter image description here

Which then requires you to afterward layer A over B, which you can do with another Alpha Over:

enter image description here

Or with a mix rgb node with the alpha button enabled (in blue):

enter image description here

But you can simplify that last setup by removing the set alpha, and use C as the mixing factor instead:

enter image description here


About the Mask node, be careful about the "scene size" option, that means the node is fit according to the scene's output resolution, so if you intend to use it on a picture whose resolution is different, or more precisely isn't the same ratio, you might want to change that option to "Fixed".

$\endgroup$
2
  • 1
    $\begingroup$ Thanks for your help, think I sorted it with the last method, I'm sure I tried it before, maybe my mask area was out of range or something hence it wasn't showing anything. $\endgroup$
    – Helpme
    May 11 at 17:46
  • $\begingroup$ Glad it helped. Don't forget to upvote and checkmark that answer $\endgroup$
    – L0Lock
    May 12 at 6:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.