1
$\begingroup$

I have a texture mapped mesh, which looks normal in the 3D view, but when I run it in the blender game engine, something strange happens. Whenever there are two faces and one should be occluding the other, the furthest back face appears to be in front. Any ideas why this is happening? I've tried playing with backface culling settings and flipping mesh normals but none of that solves the problem.

$\endgroup$
  • $\begingroup$ I've just now finally managed to find some settings in the game engine that prevent this problem from happening. I had to downgrade to Blender 2.69 and then set shading to Singletexture. The problem happens with Multitexture and GLSL. $\endgroup$ – foobarbecue Mar 2 '15 at 21:24
1
$\begingroup$

It sounds like you enabled semi-transparency (alpha-blend/alpha-sort) at your meshes. This usually happens when you import the mesh from another format.

Switching off the transparency in you materials should fix the problem.

$\endgroup$
  • $\begingroup$ Thanks, that did it! I didn't even realize transparency was on. $\endgroup$ – foobarbecue Mar 26 '15 at 15:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.