7
$\begingroup$

I have Blender 2.49b and have this model:

enter image description here

When I change mode to Textured, the windows look weird:

enter image description here

When I go back to solid mode, it's normal, but the biggest problem is when I export the model, it looks like the image above. How can I fix this?

$\endgroup$
  • $\begingroup$ You probably won't get too may answers because you are using a version which is nolonger actively supported. Also the image from your first link appears to be broken. $\endgroup$ – neomonkeus Aug 28 '13 at 10:03
  • $\begingroup$ I fixed the first image.. Yes, is not supported, but only this version is compatible with the game [OMSI] $\endgroup$ – GAMELASTER Aug 28 '13 at 10:11
  • 1
    $\begingroup$ What format do you need to export? Some export formats aren't enabled by default, you may need to enable them in the addons section of the preferences. $\endgroup$ – sambler Aug 28 '13 at 10:32
  • $\begingroup$ Looks like your normals are flipped around. $\endgroup$ – CharlesL Aug 28 '13 at 11:42
  • 1
    $\begingroup$ @GAMELASTER There is a directX exporter available in 2.68 but it isn't turned on by default, try enabling it (it's in User Preferences under Addons) and see if you can import into the game. The same tips for correcting normals apply to the newer versions. $\endgroup$ – sambler Aug 28 '13 at 11:55
4
$\begingroup$

The most likely cause would be the normals, that is which way the polygon is facing, the outer side is the one that has the texture drawn on it. In edit mode select all and press CtrlN. If that makes it worse try CtrlShiftN to flip them the other way.

Worst case scenario you can select individual faces and flip the normals using Mesh->Normals->Flip (Flip normals is also available in the specials menu W)

| improve this answer | |
$\endgroup$
2
$\begingroup$

This appears to be an issue with the faces themselves rather than which mode you have selected.

I would first check to see if the faces are pointing in the wrong direction. First enable Draw Normal from the Mesh Tool Panel

enter image description here

If they are point the wrong direction then they can be flipped the correct direction using Ctrl + Shift + N. See the wiki docs - Face Normal for more information about flipping direction.

I would also check to see if these faces have been UV wrapped. In edit mode, select the faces in question. Open the UV Editor and if they have been uv'd then they should be visible for manipulating the UV layout. If not you will have to UV unwrap those faces.

You should also check to see if these faces have a texture associated with them. If they don't you will have to assign one.

At this stage if the format you are using allows it you can enable double sided.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.