I'm trying to use an Nvidia GT520 as a render device, but i have an AMD HD7770 as my main GPU. In user preferences i can choose CUDA as my compute device, and it detects my card, but when it's time to render, cpu usage is at 100% and it uses my main system memory. My monitors are connected to my AMD card. I'm using Windows 8 64 Bit, with both latest AMD, and Nvidia drivers, and rendering on Blender 2.72

  • 1
    Have you selected Cycles as your renderer at the top of the screen? Have you selected GPU on the Render tab? – Chris Dunaway Feb 24 '15 at 22:42
  • try experimental feature set in render settings to use OpenCL GPU render – Bithur Feb 24 '15 at 22:45
up vote 3 down vote accepted

Silly me, i completely forgot about the option in the renders tab, i thought the user settings was enough. Anyway it does appear to work, fur mark does show the GPU heating up.

It isn't very useful due to it's low memory and little processing power, but being on a separate GPU i can render lesser projects while doing other tasks.

I did NOT have to enable Experimental Feature Set. do not know if it changes anything.

Thanks everyone!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.