4
$\begingroup$

I'm working with a model with many materials on it. Previously, any time I would click on the Image Texture node in the node editor, it would send the image from that node into the Image Editor automatically. This is what I assume to be the intended behavior, and was very useful in going back and forth throughout my different materials and making changes to them. It has since stopped doing that, and while i can still change the texture shown in the Image Editor manually, it's definitely not as quick or ideal as having it update to match what I'm working on in the node editor. I don't recall having changed any settings, so I'm wondering what caused this change in behavior.

My first thought was to check the image pin setting, but it was off. Tried turning it on, then off, but still no dice. Also seems to persist through completely restarting the program.

I have also found that if I create an entirely new material with an image texture node, I can get the Image Editor to update... once, for that material. Then it stops working again. Any help or pointers appreciated.

$\endgroup$
4
  • $\begingroup$ can you share the file? $\endgroup$
    – Crantisz
    May 2, 2022 at 10:07
  • $\begingroup$ @Crantisz I'm working with a ripped model from a game. Is copyright a concern here at all in terms of file sharing? $\endgroup$
    – wunner
    May 3, 2022 at 21:37
  • $\begingroup$ It might also be that, in the Shader Editor, you don't have the image node containing that image selected. That's always made a difference to me. $\endgroup$ Aug 2, 2022 at 3:53
  • $\begingroup$ Did you ever get a answer for this, I'm having the same issue. $\endgroup$
    – mlamanna
    Dec 3, 2022 at 16:34

2 Answers 2

2
$\begingroup$

It sounds like you've accidentally disabled automatic updating. To check, go to the Image editor and in the view menu look for the Update automatically checkbox. It should be checked, as it is in this image. The same setting is available in the UV editor, if you'd like to check there as well.

Image Editor View menu highlighting update automatically

$\endgroup$
3
  • $\begingroup$ Hmm. This was already checked, but I toggled it and neither having it on or off makes any difference. $\endgroup$
    – wunner
    May 3, 2022 at 23:07
  • $\begingroup$ @wunner in that case, please add a blender file to your question that has the problem. (How to add a blend file) If the images aren't updating you possibly have two different image objects with the same image in them. $\endgroup$ May 4, 2022 at 0:12
  • $\begingroup$ Added the file now. $\endgroup$
    – wunner
    May 5, 2022 at 1:33
0
$\begingroup$

I had the same problem and fixed it by opening the project with "Load UI" unticked and it was fixed. It seems like some kind of bug in the UI.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .