2
$\begingroup$

I've tried following the tutorial video Create this Satisfying 3D Animation in Blender by CG Geek on YouTube and have a problem: The fluid domain is visible as a solid cube object before the fluid simulation starts. When the animation starts at frame 40 it disappears leaving the fluid sim. At frame 251, however, the cube domain is back again. The thing is, I do not need this cube domain to be visible before frame 40 and after frame 250!

I tried rebaking it with mesh turned on/off, changing size and etc but it does not work... I'm sure the solution is close and must be really simple, but just can not find it! Will somebody please help me?

The file is attached to be discovered by the all-mighty ones!!!
https://www.mediafire.com/file/wbih98nzpz15vr7/satisfyingsim.blend/file

$\endgroup$
2
  • $\begingroup$ This is normal behavior that the domain cube is visible when the simulation is not active. You need to hide or replace it. In the video, the simulation is baked for frames 1 to 200. Yours is baked for frames 40 to 250. Also, the other cube moves up and down. Maybe it's hidden for the first 40 frames? The video is a bit hectic and you have to pay close attention. (sorry, I'm too lazy for that) $\endgroup$
    – Blunder
    Apr 29, 2022 at 16:31
  • $\begingroup$ did anyone figure out the best solution to this? I'm having the same problem. Thanks $\endgroup$ Feb 8, 2023 at 17:18

1 Answer 1

2
$\begingroup$

It is simply a matter of inserting a keyframe to turn on/off the render camera at appropriate times for your domain. Right-click on the camera icon by your domain and it can be keyframed just like everything else.

$\endgroup$
1
  • $\begingroup$ But why is it so. Its a lil bit annoying, when you wanna render a OpenVDB sequence and the first and last frame somehow has this filled box data, these files are also much bigger. I had to set the simulation from 0 to 36 and then delete in files the 0 and the 36th to get it without. Thats a lil bit tedious actually... $\endgroup$
    – Gordon1fm
    Aug 25, 2023 at 20:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .