I downloaded the latest Blender (3.1.2) as a ZIP and unzipped it, because I want to execute it alongside other Blender versions that I have installed.

Every time I try to execute blender.exe I get an annoying Windows popup: "The app you're trying to install isn't a Microsoft-verified app..." If I select "Install anyway" it runs.

  • I'm not trying to install anything. Why doesn't Windows know this? (I guess I'll need to ask Microsoft too.)

  • Reconfiguring Windows to "install from anywhere" is a terrible workaround, and not really a solution at all.

  • Does anyone else see this? Does anyone have an explanation / workaround / solution? Thanks.

  • $\begingroup$ Where did you download the zip from? This should not happen with zips from blender.org. $\endgroup$ Apr 27, 2022 at 16:45
  • $\begingroup$ I downloaded the "latest", as a zip, from blender.org. $\endgroup$ Apr 27, 2022 at 20:57
  • $\begingroup$ I had done basically the same for 3.0, 3.0.1 - they didn't act this way. I got one popup warning, I said "install anyway", and never got nagged again. $\endgroup$ Apr 27, 2022 at 21:06
  • $\begingroup$ tried blender.org:zip:3.1.1 - nok tried blender.org:zip:3.1.0 - nok $\endgroup$ Apr 27, 2022 at 21:47
  • $\begingroup$ sounds like there's a problem with Windows Defender, or whatever alternative anti-virus you're using, then. Maybe try one of the Windows forums? $\endgroup$ Apr 27, 2022 at 23:17


You must log in to answer this question.

Browse other questions tagged .