At first I thought this was just a problem where in I couldn't move objects in object mode, however I now see this is a bigger issue.

If I were to, say, try and do a simple animation with he default cube, this is what happens...

I set an initial keyframe for the cube's location, and then when I advance the timeline and try to move the cube only its origin moves. The only way I can move the cube itself is in edit mode. However, when I set a keyframe for the new location and then run this simple animation the cube doesn't move. The only thing moving on my screen is the dot representing its origin, which I see moving from position one to position two.

Basically, I'm unable to animate with Blender because of this...

Any ideas? (The transform options under "tool" are all unchecked, btw).


  • $\begingroup$ That sounds like a glitch based on what you've written. I can't think of an explanation but maybe try to reinstall Blender? $\endgroup$
    – Onyx
    Apr 26, 2022 at 15:15
  • $\begingroup$ This seems like a rendering issue. Please check that you have a current graphics driver installed. $\endgroup$
    – Robert Gützkow
    Apr 26, 2022 at 15:16
  • $\begingroup$ Certainly works fine on my computer. Have you used previous versions of Blender without problem, and just run into this problem with a new install/upgrade? $\endgroup$
    – paddyg
    Apr 26, 2022 at 15:24
  • $\begingroup$ This has been an issue for some time. For how I typically use blender--posing models for image renders and video editing--I've been able to work around this issue. But, obviously, a workaround isn't viable in this case. And, yes, I've tried reinstalling Blender. Still no-go. $\endgroup$
    – J.L. Reid
    Apr 26, 2022 at 16:10
  • $\begingroup$ Just for more info, I'm running Blender 3.1.2 on Archlinux. I use openbox without a desktop environment. The main quirk there is that Blender doesn't register my middle mouse button clicks, but I can live without that. $\endgroup$
    – J.L. Reid
    Apr 26, 2022 at 16:12

1 Answer 1


This may be because your blender options is set to only affect the object's origin. You can change this by clicking the Options button in the upper right corner of the 3D viewport and unchecking the Origins option. This should allow you to move the mesh normally again.

A visual showing the location of the Affect Only Origins checkbox

Video link describing it in more detail.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .