5
$\begingroup$

I am working with a software suite that ignores imported normals and relies entirely on a baked normal map. This messes up the shading of my model as I cannot use the "Smooth Shading" option to smooth vertex normals.

Is there a way to bake this smooth shading into a normal map? Any help would be appreciated.

$\endgroup$
1
  • 2
    $\begingroup$ I don't understand why you "cannot" use smooth shading. That software ignores normals, but it doesn't mean you cannot smooth the mesh for baking normal map in Blender. $\endgroup$ Feb 23 '15 at 5:45
7
$\begingroup$

You can use the bake selected to active feature.

  1. Duplicate your object.
  2. Set one copy to smooth, and the other to sharp.
  3. Add a UV map and image to the sharp one.
  4. Select the smooth one first, then the sharp one (so the sharp one is active).
  5. Enable Selected to active in the bake settings.
  6. Set Bake Mode to Normals.
  7. Press Bake!

You can also use this trick to add bevelled edges for low-poly models. Just add a bevel modifier to the "smooth" object.

enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ By the way, that UV mapping shown above may not work well because of the interpolation between faces. You might need to make a UV map that has each face in its own island. $\endgroup$
    – z0r
    Feb 23 '15 at 12:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.